summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorGeorg Brandl <georg@python.org>2010-05-22 12:59:18 +0200
committerGeorg Brandl <georg@python.org>2010-05-22 12:59:18 +0200
commit62f2f288940f2b9a53657918348257eeae337921 (patch)
tree19f70db5585f6cc4baefd6cf7ff3e1abcd802f9b /setup.py
parentbca665dca512d21380e8e6a0d740b1095afb5e4e (diff)
parent9d916cb2cfd032722a6287269a8e84e3681a906c (diff)
downloadsphinx-62f2f288940f2b9a53657918348257eeae337921.tar.gz
merge with 0.6
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py28
1 files changed, 15 insertions, 13 deletions
diff --git a/setup.py b/setup.py
index f16aa417..fbc622a9 100644
--- a/setup.py
+++ b/setup.py
@@ -14,35 +14,37 @@ import sphinx
long_desc = '''
Sphinx is a tool that makes it easy to create intelligent and beautiful
-documentation for Python projects (or other documents consisting of
-multiple reStructuredText sources), written by Georg Brandl.
-It was originally created to translate the new Python documentation,
-but has now been cleaned up in the hope that it will be useful to many
-other projects.
+documentation for Python projects (or other documents consisting of multiple
+reStructuredText sources), written by Georg Brandl. It was originally created
+for the new Python documentation, and has excellent facilities for Python
+project documentation, but C/C++ is supported as well, and more languages are
+planned.
Sphinx uses reStructuredText as its markup language, and many of its strengths
-come from the power and straightforwardness of reStructuredText and its
-parsing and translating suite, the Docutils.
+come from the power and straightforwardness of reStructuredText and its parsing
+and translating suite, the Docutils.
-Although it is still under constant development, the following features
-are already present, work fine and can be seen "in action" in the Python docs:
+Among its features are the following:
-* Output formats: HTML (including Windows HTML Help), plain text and LaTeX,
- for printable PDF versions
+* Output formats: HTML (including derivative formats such as HTML Help, Epub
+ and Qt Help), plain text, manual pages and LaTeX or direct PDF output
+ using rst2pdf
* Extensive cross-references: semantic markup and automatic links
for functions, classes, glossary terms and similar pieces of information
* Hierarchical structure: easy definition of a document tree, with automatic
links to siblings, parents and children
* Automatic indices: general index as well as a module index
* Code handling: automatic highlighting using the Pygments highlighter
+* Flexible HTML output using the Jinja 2 templating engine
* Various extensions are available, e.g. for automatic testing of snippets
- and inclusion of appropriately formatted docstrings.
+ and inclusion of appropriately formatted docstrings
+* Setuptools integration
A development egg can be found `here
<http://bitbucket.org/birkenfeld/sphinx/get/tip.gz#egg=Sphinx-dev>`_.
'''
-requires = ['Pygments>=0.8', 'Jinja2>=2.1', 'docutils>=0.4']
+requires = ['Pygments>=0.8', 'Jinja2>=2.2', 'docutils>=0.4']
if sys.version_info < (2, 4):
print 'ERROR: Sphinx requires at least Python 2.4 to run.'