summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorGeorg Brandl <georg@python.org>2010-08-21 22:14:57 +0200
committerGeorg Brandl <georg@python.org>2010-08-21 22:14:57 +0200
commit5a02e9343f9456f0b7b16c81aa28405e227ab54b (patch)
tree917da2855da0d334ce6eb51b5f2926c6470d6d31 /setup.py
parenteee1cc940ad300355e26c1fa91cd202736535bf4 (diff)
downloadsphinx-5a02e9343f9456f0b7b16c81aa28405e227ab54b.tar.gz
Invert setup.py uuid logic.
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py10
1 files changed, 5 insertions, 5 deletions
diff --git a/setup.py b/setup.py
index af9e660c..3b1d2d91 100644
--- a/setup.py
+++ b/setup.py
@@ -44,7 +44,7 @@ A development egg can be found `here
<http://bitbucket.org/birkenfeld/sphinx/get/tip.gz#egg=Sphinx-dev>`_.
'''
-requires = ['Pygments>=0.8', 'Jinja2>=2.2', 'docutils>=0.5', 'uuid>=1.30']
+requires = ['Pygments>=0.8', 'Jinja2>=2.2', 'docutils>=0.5']
if sys.version_info < (2, 4):
print('ERROR: Sphinx requires at least Python 2.4 to run.')
@@ -61,10 +61,10 @@ if sys.version_info < (2, 5):
except:
pass
else:
- del requires[-2]
-elif sys.version_info >= (2, 5):
- # An uuid module has been added to the stdlib in 2.5
- del requires[-1]
+ del requires[-1]
+
+ # The uuid module is new in the stdlib in 2.5
+ requires.append('uuid>=1.30')
# Provide a "compile_catalog" command that also creates the translated