summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
authorDasIch <dasdasich@gmail.com>2010-05-16 23:56:44 +0200
committerDasIch <dasdasich@gmail.com>2010-05-16 23:56:44 +0200
commit9cfb1bb68cdd54761c67aff19965307dec270e53 (patch)
tree22e98212af805f35a20934fe745330ee9aa94ed7 /Makefile
parentc69f37339b1832f69a7820c50a8bcc1b21eb3ae8 (diff)
downloadsphinx-9cfb1bb68cdd54761c67aff19965307dec270e53.tar.gz
Keep under 80 chars per line in the Makefile
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile15
1 files changed, 9 insertions, 6 deletions
diff --git a/Makefile b/Makefile
index 2672aad4..cf4f292f 100644
--- a/Makefile
+++ b/Makefile
@@ -2,12 +2,14 @@ PYTHON ?= python
export PYTHONPATH = $(shell echo "$$PYTHONPATH"):./sphinx
-.PHONY: all check clean clean-pyc clean-patchfiles clean-generated pylint reindent test
+.PHONY: all check clean clean-pyc clean-patchfiles clean-generated pylint \
+ reindent test
-DONT_CHECK = -i build -i dist -i sphinx/style/jquery.js -i sphinx/pycode/pgen2 \
- -i sphinx/util/smartypants.py -i .ropeproject -i doc/_build -i tests/path.py \
- -i tests/coverage.py -i env -i utils/convert.py -i utils/reindent3.py \
- -i utils/check_sources3.py
+DONT_CHECK = -i build -i dist -i sphinx/style/jquery.js \
+ -i sphinx/pycode/pgen2 -i sphinx/util/smartypants.py \
+ -i .ropeproject -i doc/_build -i tests/path.py \
+ -i tests/coverage.py -i env -i utils/convert.py \
+ -i utils/reindent3.py -i utils/check_sources3.py -i .tox
all: clean-pyc check test
@@ -49,7 +51,8 @@ test: build
@cd tests; $(PYTHON) run.py -d -m '^[tT]est' $(TEST)
covertest: build
- @cd tests; $(PYTHON) run.py -d -m '^[tT]est' --with-coverage --cover-package=sphinx $(TEST)
+ @cd tests; $(PYTHON) run.py -d -m '^[tT]est' --with-coverage \
+ --cover-package=sphinx $(TEST)
build:
@$(PYTHON) setup.py build