summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
authorgeorg.brandl <devnull@localhost>2007-08-15 09:00:54 +0000
committergeorg.brandl <devnull@localhost>2007-08-15 09:00:54 +0000
commit0422e4d0f09fb62dedd218a2276ef024fc32454a (patch)
tree0b85849e268f863b74fb276036766c316758fe1f /Makefile
parentc256f79bef5fb2e9fb172f1e23b80239c7ac5aae (diff)
downloadsphinx-0422e4d0f09fb62dedd218a2276ef024fc32454a.tar.gz
Merge the Mac library part into the Library part.
The "Using Python on the Mac" is now a HOWTO.
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile6
1 files changed, 5 insertions, 1 deletions
diff --git a/Makefile b/Makefile
index f1f52a87..f309cc22 100644
--- a/Makefile
+++ b/Makefile
@@ -10,13 +10,17 @@ check:
@$(PYTHON) utils/check_sources.py -i sphinx/style/jquery.js sphinx
@$(PYTHON) utils/check_sources.py converter
-clean: clean-pyc
+clean: clean-pyc clean-patchfiles
clean-pyc:
find . -name '*.pyc' -exec rm -f {} +
find . -name '*.pyo' -exec rm -f {} +
find . -name '*~' -exec rm -f {} +
+clean-patchfiles:
+ find . -name '*.orig' -exec rm -f {} +
+ find . -name '*.rej' -exec rm -f {} +
+
pylint:
@pylint --rcfile utils/pylintrc sphinx converter