summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
authorDasIch <dasdasich@gmail.com>2010-05-23 01:34:52 +0200
committerDasIch <dasdasich@gmail.com>2010-05-23 01:34:52 +0200
commit305c90ec8f4e09b4fff825bdef5bd3af78850e88 (patch)
tree99127ed07001a7bb115c4e532aea80b4397e49c1 /Makefile
parent3920289eaa99fde45b8656a25a102ab82da4e77d (diff)
downloadsphinx-305c90ec8f4e09b4fff825bdef5bd3af78850e88.tar.gz
make now works without python3
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile10
1 files changed, 7 insertions, 3 deletions
diff --git a/Makefile b/Makefile
index ecc7722c..21a87e36 100644
--- a/Makefile
+++ b/Makefile
@@ -11,12 +11,13 @@ DONT_CHECK = -i build -i dist -i sphinx/style/jquery.js \
-i tests/coverage.py -i env -i utils/convert.py \
-i utils/reindent3.py -i utils/check_sources3.py -i .tox
-all: clean-pyc check test
+all: clean-pyc clean-backupfiles check test
-check: convert-utils
ifeq ($(PYTHON), python3)
+check: convert-utils
@$(PYTHON) utils/check_sources3.py $(DONT_CHECK) .
else
+check:
@$(PYTHON) utils/check_sources.py $(DONT_CHECK) .
endif
@@ -40,10 +41,11 @@ clean-generated:
pylint:
@pylint --rcfile utils/pylintrc sphinx
-reindent: convert-utils
ifeq ($(PYTHON), python3)
+reindent: convert-utils
@$(PYTHON) utils/reindent3.py -r -n .
else
+reindent:
@$(PYTHON) utils/reindent.py -r -n .
endif
@@ -57,5 +59,7 @@ covertest: build
build:
@$(PYTHON) setup.py build
+ifeq ($(PYTHON), python3)
convert-utils:
@python3 utils/convert.py -i utils/convert.py utils/
+endif