summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGeorg Brandl <georg@python.org>2011-09-25 08:31:27 +0200
committerGeorg Brandl <georg@python.org>2011-09-25 08:31:27 +0200
commit73104e7d962fdabcdbec8c4103209ba1a152bd52 (patch)
tree2be6c6a6b018fd2fb74e524cf7d91a9b5607dfcf
parentbbe5c12d561a81f6be1887448e247ee099737498 (diff)
downloadsphinx-73104e7d962fdabcdbec8c4103209ba1a152bd52.tar.gz
Upgrade the version requirements.
-rw-r--r--CHANGES6
-rw-r--r--setup.py2
2 files changed, 7 insertions, 1 deletions
diff --git a/CHANGES b/CHANGES
index 1fe5ee64..b96a7eb1 100644
--- a/CHANGES
+++ b/CHANGES
@@ -8,6 +8,12 @@ Incompatible changes
value anymore. (It was the only thing that the directive did output, and
therefore quite inconsistent.)
+* Removed support for old dependency versions; requirements are now:
+
+ - Pygments >= 1.2
+ - Docutils >= 0.7
+ - Jinja2 >= 2.3
+
Features added
--------------
diff --git a/setup.py b/setup.py
index c73facaa..a84ac7bf 100644
--- a/setup.py
+++ b/setup.py
@@ -44,7 +44,7 @@ A development egg can be found `here
<http://bitbucket.org/birkenfeld/sphinx/get/tip.gz#egg=Sphinx-dev>`_.
'''
-requires = ['Pygments>=0.8', 'Jinja2>=2.2', 'docutils>=0.5']
+requires = ['Pygments>=1.2', 'Jinja2>=2.3', 'docutils>=0.7']
if sys.version_info < (2, 4):
print('ERROR: Sphinx requires at least Python 2.4 to run.')