summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py8
1 files changed, 5 insertions, 3 deletions
diff --git a/setup.py b/setup.py
index 4ca442a..4acfb81 100644
--- a/setup.py
+++ b/setup.py
@@ -41,6 +41,10 @@ with codecs.open(
# We let it die a horrible tracebacking death if reading the file fails.
# We couldn't sensibly recover anyway: we need the long description.
+install_requires = ['six']
+if sys.version_info[:2] < (2, 7):
+ install_requires.append('ordereddict')
+
setup (
name = 'singledispatch',
version = '3.4.0.0',
@@ -56,9 +60,7 @@ setup (
license = 'MIT',
py_modules = ('singledispatch', 'singledispatch_helpers'),
zip_safe = True,
- install_requires = [
- 'six',
- ],
+ install_requires = install_requires,
classifiers = [
'Development Status :: 5 - Production/Stable',
'Intended Audience :: Developers',