summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py78
1 files changed, 78 insertions, 0 deletions
diff --git a/setup.py b/setup.py
new file mode 100644
index 0000000..834e9f1
--- /dev/null
+++ b/setup.py
@@ -0,0 +1,78 @@
+#!/usr/bin/python
+# -*- coding: utf-8 -*-
+
+"""This library brings functools.singledispatch from Python 3.4 to Python 2.6-3.3."""
+
+# Copyright (C) 2013 by Łukasz Langa
+#
+# Permission is hereby granted, free of charge, to any person obtaining a copy
+# of this software and associated documentation files (the "Software"), to deal
+# in the Software without restriction, including without limitation the rights
+# to use, copy, modify, merge, publish, distribute, sublicense, and/or sell
+# copies of the Software, and to permit persons to whom the Software is
+# furnished to do so, subject to the following conditions:
+
+# The above copyright notice and this permission notice shall be included in
+# all copies or substantial portions of the Software.
+
+# THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
+# IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
+# FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE
+# AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER
+# LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM,
+# OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN
+# THE SOFTWARE.
+
+import os
+import sys
+import codecs
+from setuptools import setup, find_packages
+
+PY3 = sys.version_info[0] == 3
+
+if not PY3:
+ reload(sys)
+ sys.setdefaultencoding('utf8')
+
+with codecs.open(
+ os.path.join(os.path.dirname(__file__), 'README.rst'), 'r', 'utf8',
+) as ld_file:
+ long_description = ld_file.read()
+# We let it die a horrible tracebacking death if reading the file fails.
+# We couldn't sensibly recover anyway: we need the long description.
+
+setup (
+ name = 'singledispatch',
+ version = '3.4.0.0',
+ author = 'Łukasz Langa',
+ author_email = 'lukasz@langa.pl',
+ description = __doc__,
+ long_description = long_description,
+ url = 'http://docs.python.org/3/library/functools.html'
+ '#functools.singledispatch',
+ keywords = 'single dispatch generic functions singledispatch '
+ 'genericfunctions decorator backport',
+ platforms = ['any'],
+ license = 'MIT',
+ py_modules = ('singledispatch',),
+ zip_safe = True,
+ install_requires = [
+ 'six',
+ ],
+ classifiers = [
+ 'Development Status :: 5 - Production/Stable',
+ 'Intended Audience :: Developers',
+ 'License :: OSI Approved :: MIT License',
+ 'Natural Language :: English',
+ 'Operating System :: OS Independent',
+ 'Programming Language :: Python',
+ 'Programming Language :: Python :: 2',
+ 'Programming Language :: Python :: 2.6',
+ 'Programming Language :: Python :: 2.7',
+ 'Programming Language :: Python :: 3',
+ 'Programming Language :: Python :: 3.2',
+ 'Programming Language :: Python :: 3.3',
+ 'Topic :: Software Development :: Libraries',
+ 'Topic :: Software Development :: Libraries :: Python Modules',
+ ]
+)