summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
author?ukasz Langa <lukasz@langa.pl>2013-05-31 13:05:08 +0200
committer?ukasz Langa <lukasz@langa.pl>2013-05-31 13:05:08 +0200
commit00d8f4aaf5de1f40ec8ca204b7dce75b5a974dca (patch)
treef6fe47a91c403950f6e4893faa6ad2cd4c9ddc1d
parent7608b45137e9b06d127c25550821f11a644479dd (diff)
downloadsingledispatch-00d8f4aaf5de1f40ec8ca204b7dce75b5a974dca.tar.gz
Release 3.4.0.13.4.0.1
-rw-r--r--README.rst18
-rw-r--r--setup.py2
2 files changed, 19 insertions, 1 deletions
diff --git a/README.rst b/README.rst
index e1e345c..6b03da7 100644
--- a/README.rst
+++ b/README.rst
@@ -145,6 +145,24 @@ members of the core CPython team:
Change Log
----------
+3.4.0.1
+~~~~~~~
+
+Updated to the reference implementation as of 31-May-2013.
+
+* better performance
+
+* fixed a corner case with PEP 435 enums
+
+* calls to `dispatch()` also cached
+
+* dispatching algorithm now now a module-level routine called `_find_impl()`
+ with a simplified implementation and proper documentation
+
+* `dispatch()` now handles all caching-related activities
+
+* terminology more consistent: "overload" -> "implementation"
+
3.4.0.0
~~~~~~~
diff --git a/setup.py b/setup.py
index 4acfb81..9f6c072 100644
--- a/setup.py
+++ b/setup.py
@@ -47,7 +47,7 @@ if sys.version_info[:2] < (2, 7):
setup (
name = 'singledispatch',
- version = '3.4.0.0',
+ version = '3.4.0.1',
author = 'Ɓukasz Langa',
author_email = 'lukasz@langa.pl',
description = __doc__,