summaryrefslogtreecommitdiff
path: root/testing/test_file_finder.py
diff options
context:
space:
mode:
Diffstat (limited to 'testing/test_file_finder.py')
-rw-r--r--testing/test_file_finder.py5
1 files changed, 4 insertions, 1 deletions
diff --git a/testing/test_file_finder.py b/testing/test_file_finder.py
index d7b6d11..e5c2437 100644
--- a/testing/test_file_finder.py
+++ b/testing/test_file_finder.py
@@ -9,7 +9,10 @@ from setuptools_scm.integration import find_files
@pytest.fixture(params=["git", "hg"])
def inwd(request, wd, monkeypatch):
if request.param == "git":
- wd("git init")
+ try:
+ wd("git init")
+ except FileNotFoundError:
+ pytest.skip("git executable not found")
wd("git config user.email test@example.com")
wd('git config user.name "a test"')
wd.add_command = "git add ."