summaryrefslogtreecommitdiff
path: root/testing/runtests_travis.py
diff options
context:
space:
mode:
Diffstat (limited to 'testing/runtests_travis.py')
-rw-r--r--testing/runtests_travis.py21
1 files changed, 0 insertions, 21 deletions
diff --git a/testing/runtests_travis.py b/testing/runtests_travis.py
deleted file mode 100644
index d2d5f9e..0000000
--- a/testing/runtests_travis.py
+++ /dev/null
@@ -1,21 +0,0 @@
-
-from subprocess import call
-
-import os
-
-if os.environ.get("TOXENV"):
- # normal tox run, lets jsut have tox do its job
- import tox
-
- tox.cmdline()
-elif os.environ.get("SELFINSTALL"):
- # self install testing needs some clarity
- # so its being executed without any other tools running
- call("python setup.py sdist", shell=True)
- call("easy_install dist/*", shell=True)
- import pkg_resources
-
- dist = pkg_resources.get_distribution("setuptools_scm")
- import setuptools_scm
-
- assert dist.version == setuptools_scm.get_version(), dist.version