summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--setup.cfg2
-rw-r--r--tox.ini12
2 files changed, 7 insertions, 7 deletions
diff --git a/setup.cfg b/setup.cfg
index 744d43f..c0a58c8 100644
--- a/setup.cfg
+++ b/setup.cfg
@@ -8,7 +8,7 @@ author = Ronny Pfannschmidt
author_email = opensource@ronnypfannschmidt.de
description = the blessed package to manage your versions by scm tags
long_description= file:README.rst
-
+long_description_content_type=text/x-rst
classifiers=
Development Status :: 5 - Production/Stable
diff --git a/tox.ini b/tox.ini
index 4e38757..5f1143e 100644
--- a/tox.ini
+++ b/tox.ini
@@ -1,5 +1,5 @@
[tox]
-envlist=py{27,34,35,36,37,38,39}-test,flake8,check_readme,py{27,37}-selfcheck
+envlist=py{27,34,35,36,37,38,39}-test,flake8,check_readme,check-dist,py{27,37}-selfcheck,docs
[pytest]
testpaths=testing
@@ -46,21 +46,21 @@ commands =
skip_install=True
setenv = SETUPTOOLS_SCM_PRETEND_VERSION=2.0
deps=
- readme
check-manifest
+ docutils
commands=
- python setup.py check -r
rst2html.py README.rst {envlogdir}/README.html --strict []
check-manifest
-[testenv:upload]
+[testenv:check_dist]
deps=
wheel
twine
commands=
- python setup.py clean --all rotate -k - -m .whl,.tar.gz,.zip
+ python setup.py clean --all rotate -k 0 -m .whl,.tar.gz,.zip
python setup.py -q egg_info
- python setup.py -q sdist --formats zip bdist_wheel register
+ python setup.py -q sdist --formats zip bdist_wheel
+ twine check dist/*