summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorRonny Pfannschmidt <opensource@ronnypfannschmidt.de>2015-02-26 08:12:04 +0100
committerRonny Pfannschmidt <opensource@ronnypfannschmidt.de>2015-02-26 08:12:04 +0100
commitf56c5b9672439758648f3f77db85e48dd79aa656 (patch)
tree7fce0b368f672f77c361a8e6da4b41550bac2ebc /setup.py
parent0f007c082306f95693e33aae6f109740913a7560 (diff)
downloadsetuptools-scm-f56c5b9672439758648f3f77db85e48dd79aa656.tar.gz
better note
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py10
1 files changed, 6 insertions, 4 deletions
diff --git a/setup.py b/setup.py
index 5c9dc56..cd630ce 100644
--- a/setup.py
+++ b/setup.py
@@ -1,11 +1,13 @@
-"""
+"""\
important note:
the setup of setuptools_scm is self-using,
-the first execution of setup.py egg_info
+the first execution of `python setup.py egg_info`
will generate partial data
-its critical to run egg_info
-once before running sdist in a fresh checkouts
+its critical to run `python setup.py egg_info`
+once before running sdist or easy_install on a fresh checkouts
+
+pip usage is recommended
"""
from __future__ import print_function
import os