summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorRonny Pfannschmidt <opensource@ronnypfannschmidt.de>2015-02-26 08:07:48 +0100
committerRonny Pfannschmidt <opensource@ronnypfannschmidt.de>2015-02-26 08:07:48 +0100
commit0f007c082306f95693e33aae6f109740913a7560 (patch)
tree6dfa103cb80cbf4489a144226f7664aed8aa7356 /setup.py
parent4c5ee3737996a01477c76082701ef4ca9ebfe83a (diff)
downloadsetuptools-scm-0f007c082306f95693e33aae6f109740913a7560.tar.gz
print the note when using setup.py in a fresh checkout, fixes #22
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py9
1 files changed, 6 insertions, 3 deletions
diff --git a/setup.py b/setup.py
index 4d18543..5c9dc56 100644
--- a/setup.py
+++ b/setup.py
@@ -1,18 +1,21 @@
"""
important note:
-this package is self-using,
+the setup of setuptools_scm is self-using,
the first execution of setup.py egg_info
will generate partial data
its critical to run egg_info
once before running sdist in a fresh checkouts
"""
-import pkg_resources
+from __future__ import print_function
+import os
import setuptools
+if not os.path.isdir('setuptools_scm.egg-info'):
+ print(__doc__)
-def scm_config():
+def scm_config():
from setuptools_scm.version import (
guess_next_dev_version,
get_local_node_and_date,