summaryrefslogtreecommitdiff
path: root/pyproject.toml
diff options
context:
space:
mode:
authorRonny Pfannschmidt <opensource@ronnypfannschmidt.de>2021-09-02 12:31:47 +0200
committerRonny Pfannschmidt <opensource@ronnypfannschmidt.de>2021-09-02 12:31:47 +0200
commitf25d50ab94fcbcc79fb32feed9d26d2e5362f248 (patch)
treedd706732da7f5499e4e7e7ff0e7aa0f46aabc014 /pyproject.toml
parent968103183a2993897e9d3adc76ef2e3f5c560086 (diff)
downloadsetuptools-scm-f25d50ab94fcbcc79fb32feed9d26d2e5362f248.tar.gz
restore support of old setuptools/pip while warning
* detach from packaging version parsing/class and integrate backward compat mixin * move version classes to own internal module * don't warn when pyproject.toml is missing * consistently fetch dist name from setup.cfg * extend warning with notes on minimal versions * trace to stderr instead of stdout * create extensive tests around running on old setuptools
Diffstat (limited to 'pyproject.toml')
-rw-r--r--pyproject.toml7
1 files changed, 6 insertions, 1 deletions
diff --git a/pyproject.toml b/pyproject.toml
index e161860..7dfd957 100644
--- a/pyproject.toml
+++ b/pyproject.toml
@@ -1,3 +1,8 @@
[build-system]
-requires = ["setuptools>=45", "wheel", "tomli", "packaging"]
+requires = [
+ "setuptools>=45",
+ "wheel",
+ "tomli>=1.0",
+ "packaging>=20.0"
+]
build-backend = "setuptools.build_meta"