summaryrefslogtreecommitdiff
path: root/README.rst
diff options
context:
space:
mode:
authorRonny Pfannschmidt <opensource@ronnypfannschmidt.de>2018-05-13 12:31:45 +0200
committerRonny Pfannschmidt <opensource@ronnypfannschmidt.de>2018-05-13 12:31:45 +0200
commitb27e814d70f484cc7b6f4673735b85391b25b42e (patch)
treeb063c423ea6cfad0e0b1c7670e2aeeb728ee455f /README.rst
parentac2fee8189c1540a0d05ea3020726174a2b6785a (diff)
downloadsetuptools-scm-b27e814d70f484cc7b6f4673735b85391b25b42e.tar.gz
steal pre-commit config from tox
Diffstat (limited to 'README.rst')
-rw-r--r--README.rst4
1 files changed, 2 insertions, 2 deletions
diff --git a/README.rst b/README.rst
index a20fb35..7641d6e 100644
--- a/README.rst
+++ b/README.rst
@@ -287,14 +287,14 @@ The callable must return the configuration.
# content of setup.py
import setuptools
-
+
def myversion():
from setuptools_scm.version import get_local_dirty_tag
def clean_scheme(version):
return get_local_dirty_tag(version) if version.dirty else '+clean'
return {'local_scheme': clean_scheme}
-
+
setup(
...,
use_scm_version=myversion,