summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRonny Pfannschmidt <opensource@ronnypfannschmidt.de>2020-01-08 21:08:24 +0100
committerGitHub <noreply@github.com>2020-01-08 21:08:24 +0100
commit23f8a45a4b23c9adc594e9a02c58ae39b9336575 (patch)
tree14920f3b263af17120f83627d506f92a5f1cb23d
parent76917bea58d44780e51d47ab4f81770f87fe6f76 (diff)
parentdd843c834a8be1fff03bd5fdd41cbd659173b6eb (diff)
downloadsetuptools-scm-23f8a45a4b23c9adc594e9a02c58ae39b9336575.tar.gz
Merge pull request #379 from mrg29/master
fix TOML examples
-rw-r--r--README.rst9
1 files changed, 5 insertions, 4 deletions
diff --git a/README.rst b/README.rst
index e9a5b45..dc4617a 100644
--- a/README.rst
+++ b/README.rst
@@ -30,7 +30,7 @@ for those legacy environments.
First, ensure that ``setuptools_scm`` is present during the project's
built step by specifying it as one of the build requirements.
-.. code:: ini
+.. code:: toml
# pyproject.toml
[build-system]
@@ -48,7 +48,7 @@ with those uses, consider also including a ``setup_requires`` directive
To enable version inference, add this section to your pyproject.toml:
-.. code:: ini
+.. code:: toml
# pyproject.toml
[tool.setuptools_scm]
@@ -58,11 +58,12 @@ Including this section is comparable to supplying
include arbitrary keyword arguments in that section
to be supplied to ``get_version()``. For example:
-.. code:: ini
+.. code:: toml
# pyproject.toml
+
[tool.setuptools_scm]
- write_to = pkg/version.py
+ write_to = "pkg/version.py"
``setup.py`` usage