summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRonny Pfannschmidt <opensource@ronnypfannschmidt.de>2022-05-29 21:49:56 +0200
committerRonny Pfannschmidt <opensource@ronnypfannschmidt.de>2022-05-29 21:49:56 +0200
commit97af84d79eea17f22bc99e432e3ee47edd81123e (patch)
tree0e4b18be974f3d5b88c2c002a10b5843bbca224d
parent46426e91796d2d27646b310b0df5dc730e0ab3f7 (diff)
downloadsetuptools-scm-97af84d79eea17f22bc99e432e3ee47edd81123e.tar.gz
remove integration test for setup.py error as annotations are only supported on 3.7
-rw-r--r--testing/test_integration.py14
1 files changed, 0 insertions, 14 deletions
diff --git a/testing/test_integration.py b/testing/test_integration.py
index 9997068..939bd4b 100644
--- a/testing/test_integration.py
+++ b/testing/test_integration.py
@@ -1,6 +1,5 @@
from __future__ import annotations
-import os
import sys
import textwrap
from pathlib import Path
@@ -136,19 +135,6 @@ def test_pretend_version_accepts_bad_string(
assert pyver == "0.0.0"
-def test_own_setup_fails_on_old_python(monkeypatch: pytest.MonkeyPatch) -> None:
- monkeypatch.setattr("sys.version_info", (3, 5))
- monkeypatch.syspath_prepend(os.path.dirname(os.path.dirname(__file__)))
-
- import setup
-
- with pytest.raises(
- RuntimeError,
- match="support for python < 3.6 has been removed in setuptools_scm>=6.0.0",
- ):
- setup.scm_version()
-
-
def testwarn_on_broken_setuptools() -> None:
_warn_on_old_setuptools("45")
with pytest.warns(RuntimeWarning, match="ERROR: setuptools==44"):