summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRonny Pfannschmidt <opensource@ronnypfannschmidt.de>2022-06-22 13:29:43 +0200
committerRonny Pfannschmidt <opensource@ronnypfannschmidt.de>2022-06-22 13:29:43 +0200
commit64058add0ade7f92f55ae32964288d392f7ce199 (patch)
treeb0cb28081e2ded17048f84bf26552e865d6495ac
parentf9f3bec127800c1e748c94ac9747d1d217744c1a (diff)
downloadsetuptools-scm-64058add0ade7f92f55ae32964288d392f7ce199.tar.gz
changelog
-rw-r--r--CHANGELOG.rst8
-rw-r--r--src/setuptools_scm/integration.py2
2 files changed, 8 insertions, 2 deletions
diff --git a/CHANGELOG.rst b/CHANGELOG.rst
index e714761..dd76cc2 100644
--- a/CHANGELOG.rst
+++ b/CHANGELOG.rst
@@ -1,3 +1,11 @@
+v7.0.2
+======
+
+* fix #723 and #722: remove bootstrap dependencies
+* bugfix: ensure we read the distribution name from setup.cfg
+ if needed even for pyproject
+*
+
v7.0.1
=======
diff --git a/src/setuptools_scm/integration.py b/src/setuptools_scm/integration.py
index 731c19d..db1296e 100644
--- a/src/setuptools_scm/integration.py
+++ b/src/setuptools_scm/integration.py
@@ -19,8 +19,6 @@ from .utils import trace
if TYPE_CHECKING:
from . import _types as _t
-_SKIP_PYPROJECT_HACK = False
-
def _warn_on_old_setuptools(_version: str = setuptools.__version__) -> None:
if int(_version.split(".")[0]) < 45: