summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJason R. Coombs <jaraco@jaraco.com>2019-11-25 16:10:43 -0500
committerJason R. Coombs <jaraco@jaraco.com>2019-11-25 16:18:59 -0500
commit8822f91b5aa562bc49f61654b20f0e1b71822727 (patch)
treeead1102313cd25cd475ad98b96bb5d74eb9cf03e
parente9cbdb231a59f06a508d86f2b5b14719ee4bbc34 (diff)
downloadsetuptools-scm-8822f91b5aa562bc49f61654b20f0e1b71822727.tar.gz
Prefer pep517 for building the project
-rw-r--r--appveyor.yml4
-rw-r--r--pyproject.toml3
2 files changed, 5 insertions, 2 deletions
diff --git a/appveyor.yml b/appveyor.yml
index d676e54..5319f7c 100644
--- a/appveyor.yml
+++ b/appveyor.yml
@@ -17,7 +17,7 @@ init:
- ECHO "Updating Environment"
- python -m pip install -U pip
- - python -m pip install -U wheel
+ - python -m pip install -U pep517
- python -m pip install -U --upgrade-strategy=eager tox
@@ -35,7 +35,7 @@ test_script:
after_test:
# If tests are successful, create a whl package for the project.
- - "%CMD_IN_ENV% python setup.py bdist_wheel"
+ - python -m pep517.build --binary .
- ps: "ls dist"
artifacts:
diff --git a/pyproject.toml b/pyproject.toml
new file mode 100644
index 0000000..f90d4d1
--- /dev/null
+++ b/pyproject.toml
@@ -0,0 +1,3 @@
+[build-system]
+requires = ["setuptools>=34.4", "wheel"]
+build-backend = "setuptools.build_meta"