summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJason R. Coombs <jaraco@jaraco.com>2019-11-25 22:36:17 -0500
committerGitHub <noreply@github.com>2019-11-25 22:36:17 -0500
commit6879db57d12741e7899655d0a76e493196a24845 (patch)
treefc5e10276c4495590121b1289dd1a3dcc0d717b4
parent6d09c37099246260d2dd8943a3ff166589e17c8b (diff)
parent45d920ddd19b995657f63558ddb8212acd1b50ed (diff)
downloadsetuptools-scm-6879db57d12741e7899655d0a76e493196a24845.tar.gz
Merge pull request #372 from pypa/feature/pep517-build-wheel
Prefer pep517 for building the project
-rw-r--r--MANIFEST.in1
-rw-r--r--appveyor.yml4
-rw-r--r--pyproject.toml3
3 files changed, 6 insertions, 2 deletions
diff --git a/MANIFEST.in b/MANIFEST.in
index df70a56..fc07d3e 100644
--- a/MANIFEST.in
+++ b/MANIFEST.in
@@ -7,3 +7,4 @@ include testing/*.py
include tox.ini
include *.rst
include LICENSE
+include *.toml
diff --git a/appveyor.yml b/appveyor.yml
index d676e54..5319f7c 100644
--- a/appveyor.yml
+++ b/appveyor.yml
@@ -17,7 +17,7 @@ init:
- ECHO "Updating Environment"
- python -m pip install -U pip
- - python -m pip install -U wheel
+ - python -m pip install -U pep517
- python -m pip install -U --upgrade-strategy=eager tox
@@ -35,7 +35,7 @@ test_script:
after_test:
# If tests are successful, create a whl package for the project.
- - "%CMD_IN_ENV% python setup.py bdist_wheel"
+ - python -m pep517.build --binary .
- ps: "ls dist"
artifacts:
diff --git a/pyproject.toml b/pyproject.toml
new file mode 100644
index 0000000..f90d4d1
--- /dev/null
+++ b/pyproject.toml
@@ -0,0 +1,3 @@
+[build-system]
+requires = ["setuptools>=34.4", "wheel"]
+build-backend = "setuptools.build_meta"