summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJason R. Coombs <jaraco@jaraco.com>2016-06-03 14:46:42 -0400
committerJason R. Coombs <jaraco@jaraco.com>2016-06-03 14:46:42 -0400
commit1b4cddca653b6c4c2f9c18fdfaeade1276ee446a (patch)
tree354e6805467f2d4993ab95fe02a0e3bdd1ffc620
parentf5390e98b426da854838738c86a48b87742e259d (diff)
downloadsetuptools-scm-1b4cddca653b6c4c2f9c18fdfaeade1276ee446a.tar.gz
Correct typo and clarify Sphinx recommended usage. Fixes #88.
-rw-r--r--README.rst5
1 files changed, 3 insertions, 2 deletions
diff --git a/README.rst b/README.rst
index 9b4b857..1cd2a27 100644
--- a/README.rst
+++ b/README.rst
@@ -35,12 +35,13 @@ To use setuptools_scm just modify your project's setup.py file like this:
Programmatic usage
------------------
-In oder to use setuptools_scm for sphinx config
+In order to use setuptools_scm for sphinx config, assuming the sphinx conf
+is one directory deeper than the project's root, use::
.. code:: python
from setuptools_scm import get_version
- version = get_version()
+ version = get_version(root='..', relative_to=__file__)
Notable Plugins