summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRonny Pfannschmidt <opensource@ronnypfannschmidt.de>2023-02-12 22:03:28 +0100
committerRonny Pfannschmidt <opensource@ronnypfannschmidt.de>2023-02-12 22:03:28 +0100
commitb4df9efb65854616a1ed79486340b4920f4fddaa (patch)
treef40677a40244355093e4b75a1c355870b667e83b
parent1e224324604f910d20ef625e18a29b254305417f (diff)
downloadsetuptools-scm-b4df9efb65854616a1ed79486340b4920f4fddaa.tar.gz
add pyproject-fmt
-rw-r--r--.pre-commit-config.yaml10
-rw-r--r--nextgen/vcs-versioning/pyproject.toml20
-rw-r--r--pyproject.toml4
3 files changed, 21 insertions, 13 deletions
diff --git a/.pre-commit-config.yaml b/.pre-commit-config.yaml
index 63fb75b..ced36e7 100644
--- a/.pre-commit-config.yaml
+++ b/.pre-commit-config.yaml
@@ -27,11 +27,11 @@ repos:
hooks:
- id: pyupgrade
args: [--py37-plus]
-- repo: https://github.com/asottile/setup-cfg-fmt
- rev: v2.2.0
- hooks:
- - id: setup-cfg-fmt
- args: [ --include-version-classifiers ]
+- repo: https://github.com/tox-dev/pyproject-fmt
+ rev: "0.8.0"
+ hooks:
+ - id: pyproject-fmt
+
- repo: https://github.com/pre-commit/mirrors-mypy
rev: 'v1.0.0'
hooks:
diff --git a/nextgen/vcs-versioning/pyproject.toml b/nextgen/vcs-versioning/pyproject.toml
index ae8e901..c7e5097 100644
--- a/nextgen/vcs-versioning/pyproject.toml
+++ b/nextgen/vcs-versioning/pyproject.toml
@@ -1,17 +1,20 @@
[build-system]
-requires = ["hatchling"]
build-backend = "hatchling.build"
+requires = [
+ "hatchling",
+]
[project]
name = "vcs-versioning"
-description = 'the blessed package to manage your versions by vcs metadata'
+description = "the blessed package to manage your versions by vcs metadata"
readme = "README.md"
-requires-python = ">=3.8"
+keywords = [
+]
license = "MIT"
-keywords = []
authors = [
{ name = "Ronny Pfannschmidt", email = "opensource@ronnypfannschmidt.de" },
]
+requires-python = ">=3.8"
classifiers = [
"Development Status :: 1 - Planning",
"Programming Language :: Python",
@@ -20,14 +23,17 @@ classifiers = [
"Programming Language :: Python :: 3.10",
"Programming Language :: Python :: 3.11",
]
-dependencies = []
-dynamic = ["version"]
-
+dynamic = [
+ "version",
+]
+dependencies = [
+]
[project.urls]
Documentation = "https://github.com/unknown/vcs-versioning#readme"
Issues = "https://github.com/unknown/vcs-versioning/issues"
Source = "https://github.com/unknown/vcs-versioning"
+
[tool.hatch.version]
path = "vcs_versioning/__about__.py"
diff --git a/pyproject.toml b/pyproject.toml
index 24dcf32..7f1219f 100644
--- a/pyproject.toml
+++ b/pyproject.toml
@@ -7,7 +7,6 @@ requires = [
]
[project]
-dynamic = ["version"]
name = "setuptools-scm"
description = "the blessed package to manage your versions by scm tags"
readme = "README.rst"
@@ -33,6 +32,9 @@ classifiers = [
"Topic :: System :: Software Distribution",
"Topic :: Utilities",
]
+dynamic = [
+ "version",
+]
dependencies = [
'importlib-metadata; python_version < "3.8"',
"packaging>=20",