summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRonny Pfannschmidt <opensource@ronnypfannschmidt.de>2023-02-12 22:41:18 +0100
committerRonny Pfannschmidt <opensource@ronnypfannschmidt.de>2023-02-12 22:41:18 +0100
commit933e33898dbd9344b0860e463d752a15eee4e642 (patch)
treecef9c18cb021ea241ef2e0c981726c0ba1cff9cc
parentb4df9efb65854616a1ed79486340b4920f4fddaa (diff)
downloadsetuptools-scm-933e33898dbd9344b0860e463d752a15eee4e642.tar.gz
drop self check action for legacy setuptools
-rw-r--r--.github/workflows/python-tests.yml24
1 files changed, 0 insertions, 24 deletions
diff --git a/.github/workflows/python-tests.yml b/.github/workflows/python-tests.yml
index 2753333..af4126b 100644
--- a/.github/workflows/python-tests.yml
+++ b/.github/workflows/python-tests.yml
@@ -85,30 +85,6 @@ jobs:
architecture: x64
- run: pip install -e .[toml,test] pytest virtualenv
- run: pytest --test-legacy testing/test_setuptools_support.py || true # ignore fail flaky on ci
- check_selfinstall:
- runs-on: ubuntu-latest
- strategy:
- fail-fast: false
- matrix:
- python_version: [ '3.7', '3.9', 'pypy-3.8' ]
- installer: ["pip install"]
- name: check self install - Python ${{ matrix.python_version }} via ${{ matrix.installer }}
- steps:
- - uses: actions/checkout@v3
- - name: Setup python
- uses: actions/setup-python@v4
- with:
- python-version: ${{ matrix.python_version }}
- architecture: x64
- # self install testing needs some clarity
- # so its being executed without any other tools running
- # setuptools smaller 52 is needed to do easy_install
- - run: pip install -U "setuptools<52" tomli packaging typing_extensions importlib_metadata
- - run: python setup.py egg_info
- - run: python setup.py sdist
- - run: ${{ matrix.installer }} dist/*
- - run: python testing/check_self_install.py
-
dist:
runs-on: ubuntu-latest