summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRonny Pfannschmidt <ronny.pfannschmidt@redhat.com>2021-03-04 21:54:58 +0100
committerRonny Pfannschmidt <ronny.pfannschmidt@redhat.com>2021-03-04 22:14:59 +0100
commit1d1ce65d2c34dcd5d0b4047eeb85d0dc71f089d1 (patch)
tree4008a17e943158c296ab4d3a4cbc03519bfb428a
parent298a3c37967ede783a5cf4bfcf6ccfca583ed94b (diff)
downloadsetuptools-scm-1d1ce65d2c34dcd5d0b4047eeb85d0dc71f089d1.tar.gz
fix self install pipeline with pip and old setuptoolsv5.0.2
-rw-r--r--.github/workflows/python-tests.yml8
1 files changed, 5 insertions, 3 deletions
diff --git a/.github/workflows/python-tests.yml b/.github/workflows/python-tests.yml
index 4963733..6c3d172 100644
--- a/.github/workflows/python-tests.yml
+++ b/.github/workflows/python-tests.yml
@@ -59,7 +59,8 @@ jobs:
fail-fast: false
matrix:
python_version: [ '2.7', '3.5', '3.6', '3.7', '3.8', 'pypy2', 'pypy3' ]
- name: check self install - Python ${{ matrix.python_version }}
+ installer: ["pip install", easy_install]
+ name: check self install - Python ${{ matrix.python_version }} via ${{ matrix.installer }}
steps:
- uses: actions/checkout@v1
- name: Setup python
@@ -69,10 +70,11 @@ jobs:
architecture: x64
# self install testing needs some clarity
# so its being executed without any other tools running
- - run: pip install -U setuptools
+ # setuptools smaller 52 is needed too di easy_install
+ - run: pip install -U "setuptools<52"
- run: python setup.py egg_info
- run: python setup.py sdist
- - run: easy_install dist/*
+ - run: ${{ matrix.installer }} dist/*
- run: python testing/check_self_install.py