summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristian Heimes <christian@python.org>2020-12-11 12:15:28 +0100
committerGitHub <noreply@github.com>2020-12-11 12:15:28 +0100
commitef5b97d862eb65a4137205638ee4a523d62d5de2 (patch)
tree4bbaa98960ede5a205c254acdf46b5c0e8324b42
parent4262d7670dd0d79351b405f72f423fb6d3fff8fe (diff)
downloadsetuptools-scm-ef5b97d862eb65a4137205638ee4a523d62d5de2.tar.gz
Require setuptools >=42 in pyproject.toml
I noticed that ``test_pyproject_support`` and ``test_pyproject_support_with_git`` are broken with setuptools 41.6 on Fedora 32. Tests and feature are working correctly with setuptools 42 and newer. ``tox.ini`` already requires setuptools >= 42.
-rw-r--r--pyproject.toml2
1 files changed, 1 insertions, 1 deletions
diff --git a/pyproject.toml b/pyproject.toml
index f90d4d1..8fe2f47 100644
--- a/pyproject.toml
+++ b/pyproject.toml
@@ -1,3 +1,3 @@
[build-system]
-requires = ["setuptools>=34.4", "wheel"]
+requires = ["setuptools>=42", "wheel"]
build-backend = "setuptools.build_meta"