summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRonny Pfannschmidt <opensource@ronnypfannschmidt.de>2020-12-05 01:38:25 +0100
committerGitHub <noreply@github.com>2020-12-05 01:38:25 +0100
commitd0d2973413ddd3da2896aa8805f42d11201b6ff1 (patch)
treeb395275a3e809017984602abbc1f50996d13f2a1
parentaecedd5ac260a739dabf17936ba46026d815eba8 (diff)
parent98cef487c08f530ef53b8c38bdfd8c2545b9e4a8 (diff)
downloadsetuptools-scm-d0d2973413ddd3da2896aa8805f42d11201b6ff1.tar.gz
Merge pull request #499 from RonnyPfannschmidt/fix-142-document-supported-scms
Fix 142 document supported scms
-rw-r--r--CHANGELOG.rst1
-rw-r--r--README.rst7
-rw-r--r--setup.cfg2
-rw-r--r--tox.ini12
4 files changed, 15 insertions, 7 deletions
diff --git a/CHANGELOG.rst b/CHANGELOG.rst
index 34f923e..5f58599 100644
--- a/CHANGELOG.rst
+++ b/CHANGELOG.rst
@@ -10,6 +10,7 @@ v4.2.0
* enhance documentation
* consider SOURCE_DATE_EPOCH for versioning
* add a version_tuple to write_to templates
+* fix #142: clearly list supported scm
v4.1.2
diff --git a/README.rst b/README.rst
index d4b2453..d402b7e 100644
--- a/README.rst
+++ b/README.rst
@@ -9,6 +9,13 @@ Additionally ``setuptools_scm`` provides setuptools with a list of files that ar
(i.e. it automatically adds all of the SCM-managed files to the sdist).
Unwanted files must be excluded by discarding them via ``MANIFEST.in``.
+``setuptools_scm`` support the following scm out of the box:
+
+* git
+* mercurial
+
+
+
.. image:: https://github.com/pypa/setuptools_scm/workflows/python%20tests+artifacts+release/badge.svg
:target: https://github.com/pypa/setuptools_scm/actions
diff --git a/setup.cfg b/setup.cfg
index 744d43f..c0a58c8 100644
--- a/setup.cfg
+++ b/setup.cfg
@@ -8,7 +8,7 @@ author = Ronny Pfannschmidt
author_email = opensource@ronnypfannschmidt.de
description = the blessed package to manage your versions by scm tags
long_description= file:README.rst
-
+long_description_content_type=text/x-rst
classifiers=
Development Status :: 5 - Production/Stable
diff --git a/tox.ini b/tox.ini
index 4e38757..5f1143e 100644
--- a/tox.ini
+++ b/tox.ini
@@ -1,5 +1,5 @@
[tox]
-envlist=py{27,34,35,36,37,38,39}-test,flake8,check_readme,py{27,37}-selfcheck
+envlist=py{27,34,35,36,37,38,39}-test,flake8,check_readme,check-dist,py{27,37}-selfcheck,docs
[pytest]
testpaths=testing
@@ -46,21 +46,21 @@ commands =
skip_install=True
setenv = SETUPTOOLS_SCM_PRETEND_VERSION=2.0
deps=
- readme
check-manifest
+ docutils
commands=
- python setup.py check -r
rst2html.py README.rst {envlogdir}/README.html --strict []
check-manifest
-[testenv:upload]
+[testenv:check_dist]
deps=
wheel
twine
commands=
- python setup.py clean --all rotate -k - -m .whl,.tar.gz,.zip
+ python setup.py clean --all rotate -k 0 -m .whl,.tar.gz,.zip
python setup.py -q egg_info
- python setup.py -q sdist --formats zip bdist_wheel register
+ python setup.py -q sdist --formats zip bdist_wheel
+ twine check dist/*