summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRonny Pfannschmidt <opensource@ronnypfannschmidt.de>2017-01-26 16:55:27 +0100
committerRonny Pfannschmidt <opensource@ronnypfannschmidt.de>2017-01-26 16:55:27 +0100
commit2a24680d5c2099af748c579b68c74e7db6d2a8fb (patch)
treeb41bf6d6bb9a11d3c4abf2844a39bfa76fb572d2
parent46991be909cc013ffb198b2ebeddffaded171cec (diff)
downloadsetuptools-scm-2a24680d5c2099af748c579b68c74e7db6d2a8fb.tar.gz
fix up ci setup for self-install
-rw-r--r--.travis.yml5
-rw-r--r--testing/runtests_travis.py4
2 files changed, 6 insertions, 3 deletions
diff --git a/.travis.yml b/.travis.yml
index 6b27b5c..b731edf 100644
--- a/.travis.yml
+++ b/.travis.yml
@@ -9,7 +9,6 @@ python:
- '3.6-dev'
env:
- TOXENV=py-test
-- SELFINSTALL=1
matrix:
include:
@@ -17,6 +16,10 @@ matrix:
env: TOXENV=flake8
- python: '3.5'
env: TOXENV=flake8
+ - python: '2.7'
+ env: SELFINSTALL=1
+ - python: '3.5'
+ env: SELFINSTALL=1
cache:
files:
- $HOME/.pip/cache
diff --git a/testing/runtests_travis.py b/testing/runtests_travis.py
index 115fec4..3767939 100644
--- a/testing/runtests_travis.py
+++ b/testing/runtests_travis.py
@@ -3,10 +3,10 @@ from subprocess import call
import os
-if os.environ['TOXENV']:
+if os.environ.get('TOXENV'):
import tox
tox.cmdline()
-elif os.environ['SELFINSTALL']:
+elif os.environ.get('SELFINSTALL'):
call('python setup.py sdist', shell=True)
call('easy_install dist/*', shell=True)
import pkg_ressources