summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rwxr-xr-xsetup.py2
1 files changed, 2 insertions, 0 deletions
diff --git a/setup.py b/setup.py
index a371255..b8e164a 100755
--- a/setup.py
+++ b/setup.py
@@ -26,10 +26,12 @@ def get_version(package_name):
def clean_readme(fname):
+ """Cleanup README.rst for proper PyPI formatting."""
with codecs.open(fname, 'r', 'utf-8') as f:
return ''.join(
re.sub(r':\w+:`([^`]+?)( <[^<>]+>)?`', r'``\1``', line)
for line in f
+ if not (line.startswith('.. currentmodule') or line.startswith('.. toctree'))
)