summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRaphaël Barrois <raphael.barrois@polytechnique.org>2013-03-21 23:39:01 +0100
committerRaphaël Barrois <raphael.barrois@polytechnique.org>2013-03-21 23:39:01 +0100
commitb41cd673dd3ec104578403c334b55320e9d28212 (patch)
tree01fcd4f13e0bde31dec52b1bb663e73ec028812c
parent6aae60fb530f7608bc379a57a477e904a816544d (diff)
downloadsemantic-version-b41cd673dd3ec104578403c334b55320e9d28212.tar.gz
Add a Makefile for easier test running.
-rw-r--r--Makefile28
1 files changed, 28 insertions, 0 deletions
diff --git a/Makefile b/Makefile
new file mode 100644
index 0000000..22e50d8
--- /dev/null
+++ b/Makefile
@@ -0,0 +1,28 @@
+all: default
+
+
+PACKAGE_DIR = src/semantic_version
+
+
+default:
+
+
+clean:
+ find . -type f -name '*.pyc' -delete
+
+
+test:
+ python -W default setup.py test
+
+coverage:
+ coverage erase
+ coverage run "--include=$(PACKAGE_DIR)/*.py,tests/*.py" --branch setup.py test
+ coverage report "--include=$(PACKAGE_DIR)/*.py,tests/*.py"
+ coverage html "--include=$(PACKAGE_DIR)/*.py,tests/*.py"
+
+doc:
+ $(MAKE) -C docs html
+
+
+.PHONY: all default clean coverage doc test
+