summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRaphaël Barrois <raphael.barrois@polytechnique.org>2013-01-02 10:52:26 +0100
committerRaphaël Barrois <raphael.barrois@polytechnique.org>2013-01-02 10:52:26 +0100
commit658ac42850e3b4c4923365287d55ec17be4806de (patch)
tree6e3e32c850972eccad22bf5e919648414ca57bd9
parenta54c1422c7b4352dadc47476b16d05657a7adb8b (diff)
downloadsemantic-version-658ac42850e3b4c4923365287d55ec17be4806de.tar.gz
Happy New Year!
Signed-off-by: Raphaël Barrois <raphael.barrois@polytechnique.org>
-rw-r--r--LICENSE22
-rw-r--r--doc/conf.py2
-rwxr-xr-xsetup.py4
-rw-r--r--src/semantic_version/__init__.py2
-rw-r--r--src/semantic_version/base.py2
-rw-r--r--src/semantic_version/django_fields.py2
-rw-r--r--tests/django_test_app/models.py2
-rwxr-xr-xtests/test_base.py4
-rw-r--r--tests/test_django.py2
-rwxr-xr-xtests/test_match.py1
-rwxr-xr-xtests/test_parsing.py1
11 files changed, 34 insertions, 10 deletions
diff --git a/LICENSE b/LICENSE
new file mode 100644
index 0000000..504d59e
--- /dev/null
+++ b/LICENSE
@@ -0,0 +1,22 @@
+Copyright (c) 2012-2013, Raphaël Barrois
+All rights reserved.
+
+Redistribution and use in source and binary forms, with or without
+modification, are permitted provided that the following conditions are met:
+
+1. Redistributions of source code must retain the above copyright notice, this
+ list of conditions and the following disclaimer.
+2. Redistributions in binary form must reproduce the above copyright notice,
+ this list of conditions and the following disclaimer in the documentation
+ and/or other materials provided with the distribution.
+
+THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS "AS IS" AND
+ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED
+WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE
+DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT OWNER OR CONTRIBUTORS BE LIABLE FOR
+ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES
+(INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES;
+LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND
+ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
+(INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS
+SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
diff --git a/doc/conf.py b/doc/conf.py
index ab788e3..611f3c0 100644
--- a/doc/conf.py
+++ b/doc/conf.py
@@ -41,7 +41,7 @@ master_doc = 'index'
# General information about the project.
project = u'python-semanticversion'
-copyright = u'2012, Raphaël Barrois'
+copyright = u'2012-2013, Raphaël Barrois'
# The version info for the project you're documenting, acts as replacement for
# |version| and |release|, also used in various other places throughout the
diff --git a/setup.py b/setup.py
index c4c3b1e..97b131c 100755
--- a/setup.py
+++ b/setup.py
@@ -1,6 +1,6 @@
#!/usr/bin/env python
-# coding: utf-8
-# Copyright (c) 2012 Raphaël Barrois
+# -*- coding: utf-8 -*-
+# Copyright (c) 2012-2013 Raphaël Barrois
from distutils.core import setup
from distutils import cmd
diff --git a/src/semantic_version/__init__.py b/src/semantic_version/__init__.py
index c69ce88..66ae0c0 100644
--- a/src/semantic_version/__init__.py
+++ b/src/semantic_version/__init__.py
@@ -1,5 +1,5 @@
# -*- coding: utf-8 -*-
-# Copyright (c) 2012 Raphaël Barrois
+# Copyright (c) 2012-2013 Raphaël Barrois
__version__ = '2.1.2'
diff --git a/src/semantic_version/base.py b/src/semantic_version/base.py
index 66ab382..932614c 100644
--- a/src/semantic_version/base.py
+++ b/src/semantic_version/base.py
@@ -1,5 +1,5 @@
# -*- coding: utf-8 -*-
-# Copyright (c) 2012 Raphaël Barrois
+# Copyright (c) 2012-2013 Raphaël Barrois
import functools
diff --git a/src/semantic_version/django_fields.py b/src/semantic_version/django_fields.py
index d4d0042..ecc0a8f 100644
--- a/src/semantic_version/django_fields.py
+++ b/src/semantic_version/django_fields.py
@@ -1,5 +1,5 @@
# -*- coding: utf-8 -*-
-# Copyright (c) 2012 Raphaël Barrois
+# Copyright (c) 2012-2013 Raphaël Barrois
from django.db import models
from django.utils.translation import ugettext_lazy as _
diff --git a/tests/django_test_app/models.py b/tests/django_test_app/models.py
index 53ed874..9c44a29 100644
--- a/tests/django_test_app/models.py
+++ b/tests/django_test_app/models.py
@@ -1,5 +1,5 @@
# -*- coding: utf-8 -*-
-# Copyright (c) 2012 Raphaël Barrois
+# Copyright (c) 2012-2013 Raphaël Barrois
from django.db import models
from semantic_version import django_fields as semver_fields
diff --git a/tests/test_base.py b/tests/test_base.py
index ea1d8e9..52d2e84 100755
--- a/tests/test_base.py
+++ b/tests/test_base.py
@@ -1,6 +1,6 @@
#!/usr/bin/env python
-# coding: utf-8
-# Copyright (c) 2012 Raphaël Barrois
+# -*- coding: utf-8 -*-
+# Copyright (c) 2012-2013 Raphaël Barrois
"""Test the various functions from 'base'."""
diff --git a/tests/test_django.py b/tests/test_django.py
index 3185dc3..e55ec28 100644
--- a/tests/test_django.py
+++ b/tests/test_django.py
@@ -1,6 +1,6 @@
#!/usr/bin/env python
# -*- coding: utf-8 -*-
-# Copyright (c) 2012 Raphaël Barrois
+# Copyright (c) 2012-2013 Raphaël Barrois
try: # pragma: no cover
import unittest2 as unittest
diff --git a/tests/test_match.py b/tests/test_match.py
index f6888bc..e0fd5e7 100755
--- a/tests/test_match.py
+++ b/tests/test_match.py
@@ -1,5 +1,6 @@
#!/usr/bin/env python
# -*- coding: utf-8 -*-
+# Copyright (c) 2012-2013 Raphaël Barrois
import unittest
diff --git a/tests/test_parsing.py b/tests/test_parsing.py
index bf8a461..4e7b823 100755
--- a/tests/test_parsing.py
+++ b/tests/test_parsing.py
@@ -1,5 +1,6 @@
#!/usr/bin/env python
# -*- coding: utf-8 -*-
+# Copyright (c) 2012-2013 Raphaël Barrois
import unittest