summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRaphaël Barrois <raphael.barrois@polytechnique.org>2015-04-01 01:16:30 +0200
committerRaphaël Barrois <raphael.barrois@polytechnique.org>2015-04-01 01:16:30 +0200
commit5525528da2e00579777f5c2ce392a629b2634ff2 (patch)
tree4cd4e8dc1c1c900f79110750fa4091638c66a22b
parent54da2367dfc819c198ef5f48c1bffcb87a9c1c9e (diff)
downloadsemantic-version-5525528da2e00579777f5c2ce392a629b2634ff2.tar.gz
Fix README (Closes #19).
Also fixes README rendering on PyPI, hopefully.
-rw-r--r--README.rst7
-rwxr-xr-xsetup.py9
2 files changed, 10 insertions, 6 deletions
diff --git a/README.rst b/README.rst
index 7aaf383..a13871c 100644
--- a/README.rst
+++ b/README.rst
@@ -1,8 +1,3 @@
-.. python-semanticversion documentation master file, created by
- sphinx-quickstart on Wed May 16 10:41:34 2012.
- You can adapt this file completely to your liking, but it should at least
- contain the root `toctree` directive.
-
python-semanticversion
======================
@@ -27,7 +22,7 @@ Links
Getting started
===============
-Intall the package from `PyPI`_, using pip:
+Install the package from `PyPI`_, using pip:
.. code-block:: sh
diff --git a/setup.py b/setup.py
index 8f4a60b..cbce062 100755
--- a/setup.py
+++ b/setup.py
@@ -25,6 +25,14 @@ def get_version(package_name):
return '0.1.0'
+def clean_readme(fname):
+ with codecs.open(fname, 'r', 'utf-8') as f:
+ return '\n'.join(
+ re.sub(r':\w+:`([^`]+?)( <[^<>]+>)?`', r'``\1``', line)
+ for line in f
+ )
+
+
PACKAGE = 'semantic_version'
@@ -34,6 +42,7 @@ setup(
author="Raphaël Barrois",
author_email="raphael.barrois+semver@polytechnique.org",
description="A library implementing the 'SemVer' scheme.",
+ long_description=clean_readme('README.rst'),
license='BSD',
keywords=['semantic version', 'versioning', 'version'],
url='https://github.com/rbarrois/python-semanticversion',