summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthon van der Neut <anthon@mnt.org>2015-03-18 19:34:26 +0100
committerAnthon van der Neut <anthon@mnt.org>2015-03-18 19:34:26 +0100
commitafdc24a93260e9869361cb7e9855740d2dbd04d3 (patch)
treeaee0b746d9a534b49588054ba2259cfdbb52c73f
parent395f2aad5e097b6f65f0ec366eb6b5c4377453f9 (diff)
downloadruamel.yaml-afdc24a93260e9869361cb7e9855740d2dbd04d3.tar.gz
now installs and tests for pypy (by testing in setup.py and not
depending on ruamel.ordereddict if not CPython 2.x series)
-rw-r--r--Makefile12
-rw-r--r--py/__init__.py2
-rw-r--r--setup.py6
-rw-r--r--test/test_string.py3
-rw-r--r--tox.ini2
5 files changed, 12 insertions, 13 deletions
diff --git a/Makefile b/Makefile
index d4c2140..35aedc8 100644
--- a/Makefile
+++ b/Makefile
@@ -1,15 +1,9 @@
UTILNAME:=yaml
PKGNAME:=ruamel.yaml
-VERSION:=$$(python setup.py --version)
-REGEN:=/usr/local/bin/ruamel_util_new util --published --command YAML --skip-hg
+VERSION:=$(shell python setup.py --version)
+REGEN:=/home/bin/ruamel_util_new util --published --command YAML --skip-hg
include ~/.config/ruamel_util_new/Makefile.inc
-# updatereadme for inclusion of examples in README.rst
-
-clean:
- rm -rf build .tox $(PKGNAME).egg-info/ README.pdf
- find . -name "*.pyc" -exec rm {} +
- @find . -name "__pycache__" -print0 | xargs -r -0 rm -rf
-
+clean: clean_common
diff --git a/py/__init__.py b/py/__init__.py
index a16317a..3f83ebb 100644
--- a/py/__init__.py
+++ b/py/__init__.py
@@ -21,7 +21,7 @@ def _convert_version(tup):
return ret_val
-version_info = (0, 6)
+version_info = (0, 6, 1)
__version__ = _convert_version(version_info)
del _convert_version
diff --git a/setup.py b/setup.py
index 22be0f1..d02e05f 100644
--- a/setup.py
+++ b/setup.py
@@ -5,6 +5,7 @@ from __future__ import print_function
import sys
import os
+import platform
from textwrap import dedent
name_space = 'ruamel'
@@ -151,7 +152,8 @@ def main():
"ruamel.std.argparse>=0.5.1",
]
# use fast ordereddict for !!omap
- if sys.version_info[0] == 2:
+ if sys.version_info[0] == 2 and \
+ platform.python_implementation() == "CPython":
install_requires.extend(['ruamel.ordereddict'])
# if sys.version_info < (3, 4):
# install_requires.append("")
@@ -185,6 +187,8 @@ def main():
"Programming Language :: Python :: 2.7",
"Programming Language :: Python :: 3.3",
"Programming Language :: Python :: 3.4",
+ "Programming Language :: Python :: Implementation :: CPython",
+ "Programming Language :: Python :: Implementation :: PyPy",
"Topic :: Software Development :: Libraries :: Python Modules",
"Topic :: Text Processing :: Markup",
]
diff --git a/test/test_string.py b/test/test_string.py
index c962f1e..eb2e95c 100644
--- a/test/test_string.py
+++ b/test/test_string.py
@@ -61,7 +61,8 @@ class TestYAML:
""", intermediate=dict(a='ghi\njkl\n\n\n', b='x'))
def test_preserve_string_keep_at_end(self):
- # with pytest.raises(AssertionError) as excinfo:
+ # at EOF you have to specify the ... to get proper "closure"
+ # of the multiline scalar
round_trip("""
a: |+
ghi
diff --git a/tox.ini b/tox.ini
index 6edf701..414a1c9 100644
--- a/tox.ini
+++ b/tox.ini
@@ -1,5 +1,5 @@
[tox]
-envlist = py27,py34,py26,py33
+envlist = py27,py34,py26,py33,pypy
[testenv]
commands =