summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthon van der Neut <anthon@mnt.org>2015-03-26 21:26:04 +0100
committerAnthon van der Neut <anthon@mnt.org>2015-03-26 21:26:04 +0100
commit93d0a63f886d78f179e388bc5668bdae00c61f7a (patch)
tree86ba3f06e46295d28ec99b4744fd0c7f5ccfcd8e
parentab80df5141fa3f981286a52d46131ab5bb36a64b (diff)
downloadruamel.yaml-93d0a63f886d78f179e388bc5668bdae00c61f7a.tar.gz
0.7
-rw-r--r--CHANGES4
-rw-r--r--README.rst3
-rw-r--r--setup.py3
3 files changed, 6 insertions, 4 deletions
diff --git a/CHANGES b/CHANGES
index fa1c014..7f79c4e 100644
--- a/CHANGES
+++ b/CHANGES
@@ -2,9 +2,9 @@
0.7 2015-03-26
- tests (currently failing) for inline sequece and non-standard spacing between
block sequence dash and scaler (Anthony Sotille)
-- initial possibility (on list, i.e. CommentedSeq) to set the flow format
+- possibility (on list, i.e. CommentedSeq) to set the flow format
explicitly
-
+- RoundTrip capability of flow style sequences ( 'a: b, c, d' )
0.6.1 2015-03-15
- setup.py changed so ruamel.ordereddict no longer is a dependency
diff --git a/README.rst b/README.rst
index 0253c5b..5719f1b 100644
--- a/README.rst
+++ b/README.rst
@@ -26,7 +26,8 @@ Major differences with PyYAML 3.11:
the information is lost on reassignment. (This might be changed
in the future so that the preservation/folding/chomping is part of the
parent container, like comments).
-
+- RoundTrip preservation of flow style sequences ( 'a: b, c, d') (based
+ on request and test by Anthony Sottile)
Round trip including comments
=============================
diff --git a/setup.py b/setup.py
index 035c0a9..5775353 100644
--- a/setup.py
+++ b/setup.py
@@ -164,7 +164,8 @@ def main():
name=full_package_name,
version=version_str,
description=full_package_name + " is a YAML parser/emitter that "
- "supports roundtrip comment preservation",
+ "supports roundtrip preservation of comments, sequence flow style, "
+ "key order",
install_requires=install_requires,
long_description=open('README.rst').read(),
url='https://bitbucket.org/ruamel/' + package_name,