summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthon van der Neut <anthon@mnt.org>2015-06-05 09:29:28 +0200
committerAnthon van der Neut <anthon@mnt.org>2015-06-05 09:29:28 +0200
commit8801f3ecc311ff681b308bb31face88769181628 (patch)
tree599f81603e82415a98cabb40aa19f181feaf7afb
parent11d08230972aa4216549d8a41c6cb2289473d785 (diff)
downloadruamel.yaml-8801f3ecc311ff681b308bb31face88769181628.tar.gz
py3 compatibility
wheel for pypy2
-rw-r--r--py/yaml.py1
-rw-r--r--winwhl.bat1
2 files changed, 1 insertions, 1 deletions
diff --git a/py/yaml.py b/py/yaml.py
index 48411e3..3a2e669 100644
--- a/py/yaml.py
+++ b/py/yaml.py
@@ -328,7 +328,6 @@ class YAML:
"""return the last non-empty line of a block of text (stripped)
do not split or strip the complete txt
"""
- assert isinstance(txt, basestring)
pos = txt.rfind('\n')
prev_pos = len(txt)
maxloop = 10
diff --git a/winwhl.bat b/winwhl.bat
index d99eeea..95002d4 100644
--- a/winwhl.bat
+++ b/winwhl.bat
@@ -6,3 +6,4 @@ c:\python\3.4\python.exe setup.py bdist_wheel
c:\python\3.3\python.exe setup.py bdist_wheel
c:\python\3.4-32\python.exe setup.py bdist_wheel
c:\python\3.3-32\python.exe setup.py bdist_wheel
+c:\pypy2\2.5\pypy-2.5.1-win32\pypy.exe setup.py bdist_wheel