summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthon van der Neut <anthon@mnt.org>2015-05-28 12:55:53 +0200
committerAnthon van der Neut <anthon@mnt.org>2015-05-28 12:55:53 +0200
commit4053cbc74e4db875781e5d72e8019791b9805870 (patch)
treeca70c22fcabc16d53d4cda18245fdf248e9dfa05
parent289970ec0900d8b44b25137361a2e70e0f99d10e (diff)
downloadruamel.yaml-4053cbc74e4db875781e5d72e8019791b9805870.tar.gz
make purity of wheel depend on --universal
-rw-r--r--setup.py3
1 files changed, 2 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index 4d58ffd..7020476 100644
--- a/setup.py
+++ b/setup.py
@@ -68,7 +68,8 @@ if __name__ == '__main__':
# windows things this is pure, that way you would get pure python
# whl files that take precedence on Linux over source with compilable C
- Distribution.is_pure = lambda *args: True
+ if '--universal' in sys.argv:
+ Distribution.is_pure = lambda *args: True