summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthon van der Neut <anthon@mnt.org>2015-06-05 21:52:15 +0200
committerAnthon van der Neut <anthon@mnt.org>2015-06-05 21:52:15 +0200
commit340848c287ef20c6d22f4498f19caf0f8409a570 (patch)
treeef69ac541fcbb90feaabfcf3a9c26d5ecdce2872
parent8801f3ecc311ff681b308bb31face88769181628 (diff)
downloadruamel.yaml-340848c287ef20c6d22f4498f19caf0f8409a570.tar.gz
- remove tmpdir print
- update for so-30328549-yaml-preprocessor-macro-processor/ so that you can have construct_scalar return a non string
-rw-r--r--py/__init__.py2
-rw-r--r--py/constructor.py3
-rw-r--r--setup.py1
3 files changed, 4 insertions, 2 deletions
diff --git a/py/__init__.py b/py/__init__.py
index 023cba0..6449209 100644
--- a/py/__init__.py
+++ b/py/__init__.py
@@ -21,7 +21,7 @@ def _convert_version(tup):
return ret_val
-version_info = (0, 9, 5)
+version_info = (0, 9, 6)
__version__ = _convert_version(version_info)
del _convert_version
diff --git a/py/constructor.py b/py/constructor.py
index 4835e14..0cc86e3 100644
--- a/py/constructor.py
+++ b/py/constructor.py
@@ -812,6 +812,9 @@ class RoundTripConstructor(SafeConstructor):
return value
try:
return value.encode('ascii')
+ except AttributeError:
+ # in case you replace the node dynamically e.g. with a dict
+ return value
except UnicodeEncodeError:
return value
diff --git a/setup.py b/setup.py
index 8d0541c..01be376 100644
--- a/setup.py
+++ b/setup.py
@@ -123,7 +123,6 @@ def check_extensions():
tmp_dir = tempfile.mkdtemp(prefix='tmp_ruamel_yaml_')
ret_val = None
try:
- print('tmp_dir', tmp_dir)
bin_file_name = os.path.join(tmp_dir, 'test_yaml')
file_name = bin_file_name + '.c'
with open(file_name, 'w') as fp: