summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthon van der Neut <anthon@mnt.org>2015-03-27 07:02:48 +0100
committerAnthon van der Neut <anthon@mnt.org>2015-03-27 07:02:48 +0100
commit12888ae5a41e3c1cb95c9b370f4eac7e40ee6d4b (patch)
tree567583f4786236ff39110d21acca1bffa79f6751
parent7c213b38b3e20aa5f7d1c400f9b7b4d2f41e02d5 (diff)
parentb655e5a9aa23373ff1fe706b72958bac4ff33405 (diff)
downloadruamel.yaml-12888ae5a41e3c1cb95c9b370f4eac7e40ee6d4b.tar.gz
version bump, tox rerun
-rw-r--r--CHANGES6
-rw-r--r--py/constructor.py4
2 files changed, 5 insertions, 5 deletions
diff --git a/CHANGES b/CHANGES
index 7f79c4e..25e4bf4 100644
--- a/CHANGES
+++ b/CHANGES
@@ -1,15 +1,15 @@
0.7 2015-03-26
- tests (currently failing) for inline sequece and non-standard spacing between
- block sequence dash and scaler (Anthony Sotille)
-- possibility (on list, i.e. CommentedSeq) to set the flow format
+ block sequence dash and scalar (Anthony Sottile)
+- initial possibility (on list, i.e. CommentedSeq) to set the flow format
explicitly
- RoundTrip capability of flow style sequences ( 'a: b, c, d' )
0.6.1 2015-03-15
- setup.py changed so ruamel.ordereddict no longer is a dependency
if not on CPython 2.x (used to test only for 2.x, which breaks pypy 2.5.0
- reported by Anthony Sotille)
+ reported by Anthony Sottile)
0.6 2015-03-11
- basic support for scalars with preserved newlines
diff --git a/py/constructor.py b/py/constructor.py
index fa44d28..61fa8a7 100644
--- a/py/constructor.py
+++ b/py/constructor.py
@@ -931,9 +931,9 @@ class RoundTripConstructor(SafeConstructor):
# Note: we do now check for duplicate keys
omap = CommentedOrderedMap()
if node.flow_style is True:
- data.fa.set_flow_style()
+ omap.fa.set_flow_style()
elif node.flow_style is False:
- data.fa.set_block_style()
+ omap.fa.set_block_style()
yield omap
if node.comment:
omap._yaml_add_comment(node.comment[:2])