summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohannes Dewender <github@JonnyJD.net>2013-10-25 15:38:14 +0200
committerJohannes Dewender <github@JonnyJD.net>2013-10-25 16:06:04 +0200
commite5366ad538e7d728997deb2b4a7e40e56037dc71 (patch)
tree0f7ba6575cd31e11cd591cc1f6251f436dee2f38
parent3fbe7e4ccd875298326e7e4dc390e51db2518070 (diff)
downloadrtslib-fb-e5366ad538e7d728997deb2b4a7e40e56037dc71.tar.gz
rename debian package to rtslib-fb
Signed-off-by: Johannes Dewender <github@JonnyJD.net>
-rw-r--r--Makefile37
-rw-r--r--debian/control10
-rw-r--r--debian/copyright4
-rw-r--r--debian/python-rtslib-fb.dirs (renamed from debian/python-rtslib.dirs)0
-rw-r--r--debian/python-rtslib-fb.docs (renamed from debian/python-rtslib.docs)0
-rw-r--r--debian/python-rtslib-fb.install (renamed from debian/python-rtslib.install)0
-rwxr-xr-xdebian/python-rtslib-fb.postinst (renamed from debian/python-rtslib.postinst)0
-rwxr-xr-xdebian/python-rtslib-fb.preinst (renamed from debian/python-rtslib.preinst)0
-rwxr-xr-xdebian/python-rtslib-fb.prerm (renamed from debian/python-rtslib.prerm)0
-rwxr-xr-xdebian/rules3
10 files changed, 28 insertions, 26 deletions
diff --git a/Makefile b/Makefile
index 28ea08b..a3c7ce1 100644
--- a/Makefile
+++ b/Makefile
@@ -14,6 +14,7 @@
# under the License.
#
+PKGNAME = rtslib-fb
NAME = rtslib
GIT_BRANCH = $$(git branch | grep \* | tr -d \*)
VERSION = $$(basename $$(git describe --tags | tr - . | grep -o '[0-9].*$$'))
@@ -37,11 +38,11 @@ clean:
@rm -fv dpkg-buildpackage.log dpkg-buildpackage.version
@rm -frv *.rpm
@rm -fv debian/files debian/*.log debian/*.substvars
- @rm -frv debian/${NAME}-doc/ debian/python2.5-${NAME}/
- @rm -frv debian/python2.6-${NAME}/ debian/python-${NAME}/
+ @rm -frv debian/${PKGNAME}-doc/ debian/python2.5-${PKGNAME}/
+ @rm -frv debian/python2.6-${PKGNAME}/ debian/python-${PKGNAME}/
@rm -frv results
@rm -fv rpm/*.spec *.spec rpm/sed* sed*
- @rm -frv ${NAME}-*
+ @rm -frv ${PKGNAME}-*
@echo "Finished cleanup."
cleanall: clean
@@ -51,16 +52,16 @@ release: build/release-stamp
build/release-stamp:
@mkdir -p build
@echo "Exporting the repository files..."
- @git archive ${GIT_BRANCH} --prefix ${NAME}-${VERSION}/ \
+ @git archive ${GIT_BRANCH} --prefix ${PKGNAME}-${VERSION}/ \
| (cd build; tar xfp -)
@echo "Cleaning up the target tree..."
- @rm -f build/${NAME}-${VERSION}/Makefile
- @rm -f build/${NAME}-${VERSION}/.gitignore
+ @rm -f build/${PKGNAME}-${VERSION}/Makefile
+ @rm -f build/${PKGNAME}-${VERSION}/.gitignore
@echo "Fixing version string..."
@sed -i "s/__version__ = .*/__version__ = '${VERSION}'/g" \
- build/${NAME}-${VERSION}/${NAME}/__init__.py
+ build/${PKGNAME}-${VERSION}/${NAME}/__init__.py
@echo "Generating rpm specfile from template..."
- @cd build/${NAME}-${VERSION}; \
+ @cd build/${PKGNAME}-${VERSION}; \
for spectmpl in rpm/*.spec.tmpl; do \
sed -i "s/Version:\( *\).*/Version:\1${VERSION}/g" $${spectmpl}; \
mv $${spectmpl} $$(basename $${spectmpl} .tmpl); \
@@ -75,7 +76,7 @@ build/release-stamp:
hash=$$(git show HEAD --format="format:%H" -s); \
echo '* '"$${date} $${author} $${version}-1"; \
echo " - Generated from git commit $${hash}."; \
- ) >> $$(ls build/${NAME}-${VERSION}/*.spec)
+ ) >> $$(ls build/${PKGNAME}-${VERSION}/*.spec)
@echo "Generating debian changelog..."
@( \
version=$$(basename $$(git describe HEAD --tags | tr - . | grep -o '[0-9].*$$')); \
@@ -87,30 +88,30 @@ build/release-stamp:
date=$$(echo $${date} \
| awk '{print $$1, "'"$${day}"'", $$3, $$4, $$5, $$6}'); \
hash=$$(git show HEAD --format="format:%H" -s); \
- echo "${NAME} ($${version}) unstable; urgency=low"; \
+ echo "${PKGNAME} ($${version}) unstable; urgency=low"; \
echo; \
echo " * Generated from git commit $${hash}."; \
echo; \
echo " -- $${author} $${date}"; \
echo; \
- ) > build/${NAME}-${VERSION}/debian/changelog
- @find build/${NAME}-${VERSION}/ -exec \
+ ) > build/${PKGNAME}-${VERSION}/debian/changelog
+ @find build/${PKGNAME}-${VERSION}/ -exec \
touch -t $$(date -d @$$(git show -s --format="format:%at") \
+"%Y%m%d%H%M.%S") {} \;
@mkdir -p dist
@cd build; tar -c --owner=0 --group=0 --numeric-owner \
--format=gnu -b20 --quoting-style=escape \
- -f ../dist/${NAME}-${VERSION}.tar \
- $$(find ${NAME}-${VERSION} -type f | sort)
- @gzip -6 -n dist/${NAME}-${VERSION}.tar
+ -f ../dist/${PKGNAME}-${VERSION}.tar \
+ $$(find ${PKGNAME}-${VERSION} -type f | sort)
+ @gzip -6 -n dist/${PKGNAME}-${VERSION}.tar
@echo "Generated release tarball:"
- @echo " $$(ls dist/${NAME}-${VERSION}.tar.gz)"
+ @echo " $$(ls dist/${PKGNAME}-${VERSION}.tar.gz)"
@touch build/release-stamp
deb: release build/deb-stamp
build/deb-stamp:
@echo "Building debian packages..."
- @cd build/${NAME}-${VERSION}; \
+ @cd build/${PKGNAME}-${VERSION}; \
dpkg-buildpackage -rfakeroot -us -uc
@mv build/*_${VERSION}_*.deb dist/
@echo "Generated debian packages:"
@@ -124,7 +125,7 @@ build/rpm-stamp:
@build=$$(pwd)/build/rpm; dist=$$(pwd)/dist/; rpmbuild \
--define "_topdir $${build}" --define "_sourcedir $${dist}" \
--define "_rpmdir $${build}" --define "_buildir $${build}" \
- --define "_srcrpmdir $${build}" -ba build/${NAME}-${VERSION}/*.spec
+ --define "_srcrpmdir $${build}" -ba build/${PKGNAME}-${VERSION}/*.spec
@mv build/rpm/*-${VERSION}*.src.rpm dist/
@mv build/rpm/*/*-${VERSION}*.rpm dist/
@echo "Generated rpm packages:"
diff --git a/debian/control b/debian/control
index eeb95c8..cf43950 100644
--- a/debian/control
+++ b/debian/control
@@ -1,13 +1,13 @@
-Source: rtslib
+Source: rtslib-fb
Section: python
Priority: optional
-Maintainer: Jerome Martin <jxm@risingtidesystems.com>
+Maintainer: Andy Grover <andy@groveronline.com>
Build-Depends: debhelper(>= 7.0.1), python, python-epydoc
Standards-Version: 3.8.1
-Package: python-rtslib
+Package: python-rtslib-fb
Architecture: all
Depends: python (>= 2.5)|python2.5|python2.6, python-configobj, python-netifaces, python-ipaddr
-Suggests: rtslib-doc
+Suggests: python-rtslib-fb-doc
Conflicts: rtsadmin-frozen
-Description: RisingTide Systems generic SCSI target API in python.
+Description: RisingTide Systems generic SCSI target API in python (free branch).
diff --git a/debian/copyright b/debian/copyright
index 4fac94e..638eeb9 100644
--- a/debian/copyright
+++ b/debian/copyright
@@ -1,6 +1,6 @@
This package was originally debianized by Jerome Martin <jxm@risingtidesystems.com>
-on Fri Nov 18 12:00:01 UTC 2009. It is currently maintained by Jerome Martin
-<jxm@risingtidesystems.com>.
+on Fri Nov 18 12:00:01 UTC 2009. It is currently maintained by Andy Grover
+<andy@groveronline.com>.
Upstream Author: Jerome Martin <jxm@risingtidesystems.com>
diff --git a/debian/python-rtslib.dirs b/debian/python-rtslib-fb.dirs
index 7a9f9da..7a9f9da 100644
--- a/debian/python-rtslib.dirs
+++ b/debian/python-rtslib-fb.dirs
diff --git a/debian/python-rtslib.docs b/debian/python-rtslib-fb.docs
index bdb06cd..bdb06cd 100644
--- a/debian/python-rtslib.docs
+++ b/debian/python-rtslib-fb.docs
diff --git a/debian/python-rtslib.install b/debian/python-rtslib-fb.install
index f4fdef1..f4fdef1 100644
--- a/debian/python-rtslib.install
+++ b/debian/python-rtslib-fb.install
diff --git a/debian/python-rtslib.postinst b/debian/python-rtslib-fb.postinst
index 5de7eb9..5de7eb9 100755
--- a/debian/python-rtslib.postinst
+++ b/debian/python-rtslib-fb.postinst
diff --git a/debian/python-rtslib.preinst b/debian/python-rtslib-fb.preinst
index f4815e6..f4815e6 100755
--- a/debian/python-rtslib.preinst
+++ b/debian/python-rtslib-fb.preinst
diff --git a/debian/python-rtslib.prerm b/debian/python-rtslib-fb.prerm
index 8a089c4..8a089c4 100755
--- a/debian/python-rtslib.prerm
+++ b/debian/python-rtslib-fb.prerm
diff --git a/debian/rules b/debian/rules
index 9c4d6c1..327c845 100755
--- a/debian/rules
+++ b/debian/rules
@@ -3,6 +3,7 @@
build_dir = build
install_dir = debian/tmp
setup = /usr/bin/python ./setup.py --quiet
+pkgname = rtslib-fb
name = rtslib
binary: binary-indep
@@ -36,7 +37,7 @@ build-stamp:
--install-scripts $(install_dir)/bin
echo "2.5, 2.6" > $(install_dir)/lib/rtslib/.version
mkdir -p $(build_dir) doc
- cd $(build_dir); epydoc --no-sourcecode --html -n $(name) \
+ cd $(build_dir); epydoc --no-sourcecode --html -n $(pkgname) \
--exclude configobj ../$(name)/*.py
cp -r $(build_dir)/html doc/
touch build-stamp