summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py23
1 files changed, 20 insertions, 3 deletions
diff --git a/setup.py b/setup.py
index d43a593..600dc08 100644
--- a/setup.py
+++ b/setup.py
@@ -1,13 +1,24 @@
__version__ = '1.13'
-import os
+import os, sys
from setuptools import setup, find_packages
here = os.path.abspath(os.path.dirname(__file__))
README = open(os.path.join(here, 'README.rst')).read()
CHANGES = open(os.path.join(here, 'CHANGELOG.rst')).read()
+PY3 = sys.version_info[0] == 3
+extra_options = {
+ "packages": find_packages(),
+ }
+
+if PY3:
+ extra_options["use_2to3"] = True
+ if "test" in sys.argv:
+ for root, directories, files in os.walk("tests"):
+ for directory in directories:
+ extra_options["packages"].append(os.path.join(root, directory))
setup(name="Routes",
version=__version__,
@@ -16,16 +27,21 @@ setup(name="Routes",
classifiers=["Development Status :: 5 - Production/Stable",
"Intended Audience :: Developers",
"License :: OSI Approved :: BSD License",
- "Programming Language :: Python",
"Topic :: Internet :: WWW/HTTP",
"Topic :: Software Development :: Libraries :: Python Modules",
+ 'Programming Language :: Python',
+ "Programming Language :: Python :: 2",
+ "Programming Language :: Python :: 2.6",
+ "Programming Language :: Python :: 2.7",
+ "Programming Language :: Python :: 3",
+ "Programming Language :: Python :: 3.2",
+ "Programming Language :: Python :: 3.3"
],
keywords='routes webob dispatch',
author="Ben Bangert",
author_email="ben@groovie.org",
url='http://routes.groovie.org/',
license="MIT",
- packages=find_packages(),
test_suite="nose.collector",
include_package_data=True,
zip_safe=False,
@@ -33,4 +49,5 @@ setup(name="Routes",
install_requires=[
"repoze.lru>=0.3"
],
+ **extra_options
)