summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBen Bangert <ben@groovie.org>2012-03-13 10:50:53 -0700
committerBen Bangert <ben@groovie.org>2012-03-13 10:50:53 -0700
commit5aefc9bce70aa9f30bb7775bacd761b27630d5d2 (patch)
tree3d52de45431c7fac7f7749589974db81ea530e89
parent1dd6eff15e18efd04d2a03ad170048f30ad625c2 (diff)
downloadroutes-5aefc9bce70aa9f30bb7775bacd761b27630d5d2.tar.gz
handle missing profile
--HG-- branch : trunk
-rw-r--r--.travis.yml2
-rw-r--r--tests/test_functional/profile_rec.py5
2 files changed, 4 insertions, 3 deletions
diff --git a/.travis.yml b/.travis.yml
index 9ee2b3c..3e39294 100644
--- a/.travis.yml
+++ b/.travis.yml
@@ -5,6 +5,4 @@ python:
install:
- python setup.py develop
- pip install webob webtest coverage
- - sudo apt-get update
- - sudo apt-get install python-profiler
script: nosetests \ No newline at end of file
diff --git a/tests/test_functional/profile_rec.py b/tests/test_functional/profile_rec.py
index 78af6d8..28476d9 100644
--- a/tests/test_functional/profile_rec.py
+++ b/tests/test_functional/profile_rec.py
@@ -1,4 +1,7 @@
-import profile
+try:
+ import profile
+except ImportError:
+ pass
import pstats
import tempfile
import os