summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorbbangert <none@none>2006-09-15 11:36:01 -0700
committerbbangert <none@none>2006-09-15 11:36:01 -0700
commit2fb7c13fc05dd8571a3619e526c78ee4fe6cfc21 (patch)
tree6a63e731bc2821d5564752ba0cbd36cffdcc9352
parent9218ec98824f6231b8c6959ae8dd7cf76652e7e5 (diff)
downloadroutes-2fb7c13fc05dd8571a3619e526c78ee4fe6cfc21.tar.gz
[svn] Adding install/readme files.
--HG-- branch : trunk
-rw-r--r--INSTALL11
-rw-r--r--README13
2 files changed, 24 insertions, 0 deletions
diff --git a/INSTALL b/INSTALL
new file mode 100644
index 0000000..6102d5e
--- /dev/null
+++ b/INSTALL
@@ -0,0 +1,11 @@
+Installing Routes can be done the traditional way with:
+
+ python setup.py install
+
+Or directly from the CheeseShop via setuptools:
+
+ easy_install Routes
+
+Alternatively, you can copy the package to your site-packages directory
+to bypass the setuptools based install script (which requires an Internet
+connection).
diff --git a/README b/README
new file mode 100644
index 0000000..c16c06a
--- /dev/null
+++ b/README
@@ -0,0 +1,13 @@
+Routes is a Python re-implementation of the Rails routes system for mapping
+URL's to Controllers/Actions and generating URL's. Routes makes it easy to
+create pretty and concise URL's that are RESTful with little effort.
+
+Speedy and dynamic URL generation means you get a URL with minimal cruft
+(no big dangling query args). Shortcut features like Named Routes cut down
+on repetitive typing.
+
+View the INSTALL for installation instructions. Routes will typically be
+running integrated into an existing framework.
+
+For developers wishing to integrate Routes with their web
+application/framework, consult docs/integration.txt.