summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJordan Cook <jordan.cook@pioneer.com>2021-09-07 21:15:28 -0500
committerJordan Cook <jordan.cook@pioneer.com>2021-09-07 21:15:28 -0500
commitbac5e2934e14eb511705a7cc8f82811bf211b471 (patch)
tree94187b54d91261cabd1d0e2c44766429241e135a
parent5779131b4cb62a3a513285f8fba0c675db07ae66 (diff)
downloadrequests-cache-bac5e2934e14eb511705a7cc8f82811bf211b471.tar.gz
Add note to Troubleshooting section about deprecated imports
-rw-r--r--HISTORY.md2
-rw-r--r--docs/user_guide/troubleshooting.md1
-rw-r--r--pyproject.toml2
-rw-r--r--requests_cache/__init__.py2
4 files changed, 4 insertions, 3 deletions
diff --git a/HISTORY.md b/HISTORY.md
index baec5b8..3f2b93b 100644
--- a/HISTORY.md
+++ b/HISTORY.md
@@ -45,7 +45,7 @@ The following changes are meant to make certain behaviors more obvious for new u
* For consistency with other backends, rename SQLite backend classes: `backends.sqlite.Db*` -> `SQLiteCache`, `SQLiteDict`, `SQLitePickleDict`
* Add aliases for all previous parameter/class names for backwards-compatibility
-**Depedencies:**
+**Dependencies:**
* Add `appdirs` as a dependency for easier cross-platform usage of user cache directories
* Update `cattrs` from optional to required dependency
* Update `itsdangerous` from required to optional (but recommended) dependency
diff --git a/docs/user_guide/troubleshooting.md b/docs/user_guide/troubleshooting.md
index a075f5f..9573191 100644
--- a/docs/user_guide/troubleshooting.md
+++ b/docs/user_guide/troubleshooting.md
@@ -75,6 +75,7 @@ Here are some error messages you may see either in the logs or (more rarely) in
requests-cache. See `requests` documentation on
[Errors and Exceptions](https://2.python-requests.org/en/master/user/quickstart/#errors-and-exceptions)
for more details.
+* **{py:exc}`ModuleNotFoundError`**: `No module named 'requests_cache.core'`: This module was deprecated in `v0.6` and removed in `v0.8`. Just import from `requests_cache` instead of `requests_cache.core`.
* **{py:exc}`ImportError`:**
* If you see this at **import time**, it means that one or more **required** dependencies are not
installed
diff --git a/pyproject.toml b/pyproject.toml
index fb6de53..12105cb 100644
--- a/pyproject.toml
+++ b/pyproject.toml
@@ -1,6 +1,6 @@
[tool.poetry]
name = "requests-cache"
-version = "0.8.0"
+version = "0.8.1"
description = "A transparent persistent cache for the requests library"
authors = ["Roman Haritonov"]
maintainers = ["Jordan Cook"]
diff --git a/requests_cache/__init__.py b/requests_cache/__init__.py
index 93e2033..c377571 100644
--- a/requests_cache/__init__.py
+++ b/requests_cache/__init__.py
@@ -6,7 +6,7 @@ logger = getLogger(__name__)
# Version is defined in pyproject.toml.
# It's copied here to make it easier for client code to check the installed version.
-__version__ = '0.8.0'
+__version__ = '0.8.1'
def get_placeholder_class(original_exception: Exception = None):