summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJordan Cook <jordan.cook@pioneer.com>2021-08-27 16:47:55 -0500
committerJordan Cook <jordan.cook@pioneer.com>2021-08-27 16:47:55 -0500
commit5c6376896fe944174bcaade08a05f3b7c8ad989c (patch)
tree939faefcfe40238a21a7c4397defbcca538fd3ed
parenta88d1ab3a47b31ab6101f99efa18a0aeda645b2d (diff)
downloadrequests-cache-5c6376896fe944174bcaade08a05f3b7c8ad989c.tar.gz
Fix pyyaml optional dependency
-rw-r--r--poetry.lock6
-rw-r--r--pyproject.toml4
2 files changed, 5 insertions, 5 deletions
diff --git a/poetry.lock b/poetry.lock
index f80bd1e..913f8e3 100644
--- a/poetry.lock
+++ b/poetry.lock
@@ -1198,7 +1198,7 @@ docs = ["sphinx", "jaraco.packaging (>=8.2)", "rst.linker (>=1.9)"]
testing = ["pytest (>=4.6)", "pytest-checkdocs (>=2.4)", "pytest-flake8", "pytest-cov", "pytest-enabler (>=1.0.1)", "jaraco.itertools", "func-timeout", "pytest-black (>=0.3.7)", "pytest-mypy"]
[extras]
-all = ["boto3", "botocore", "itsdangerous", "pymongo", "redis", "ujson"]
+all = ["boto3", "botocore", "itsdangerous", "pymongo", "pyyaml", "redis", "ujson"]
bson = ["bson"]
docs = ["furo", "linkify-it-py", "myst-parser", "sphinx", "sphinx-autodoc-typehints", "sphinx-automodapi", "sphinx-copybutton", "sphinx-inline-tabs", "sphinx-panels", "sphinxcontrib-apidoc"]
dynamodb = ["boto3", "botocore"]
@@ -1206,12 +1206,12 @@ json = ["ujson"]
mongodb = ["pymongo"]
redis = ["redis"]
security = ["itsdangerous"]
-yaml = []
+yaml = ["pyyaml"]
[metadata]
lock-version = "1.1"
python-versions = "^3.7"
-content-hash = "37b082f9dfe33561268c2cc2e5bc8ce23302d8e97f548e9cdf5f4eb9ce974841"
+content-hash = "cd051d290c392d46b3b9bec80e3ac464e745af2d17a075fe01dfb3816faca697"
[metadata.files]
alabaster = [
diff --git a/pyproject.toml b/pyproject.toml
index d5fa9dc..374858d 100644
--- a/pyproject.toml
+++ b/pyproject.toml
@@ -70,10 +70,10 @@ redis = ["redis"]
bson = ["bson"] # BSON comes with pymongo, but can also be used as a standalone codec
json = ["ujson"] # Will optionally be used by JSON serializer for improved performance
security = ["itsdangerous"]
-yaml = ["yaml"]
+yaml = ["pyyaml"]
# All optional packages combined, for demo/evaluation purposes
-all = ["boto3", "botocore", "itsdangerous", "pymongo", "redis", "ujson", "yaml"]
+all = ["boto3", "botocore", "itsdangerous", "pymongo", "pyyaml", "redis", "ujson"]
# Documentation
docs = ["furo", "linkify-it-py", "myst-parser", "sphinx", "sphinx-autodoc-typehints",