summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJordan Cook <jordan.cook@pioneer.com>2021-09-13 18:21:41 -0500
committerJordan Cook <jordan.cook@pioneer.com>2021-09-18 17:43:12 -0500
commit86faa864900445e588b826004d594e8ab40a1c33 (patch)
tree324c5771d36fc05aef771e84b007c42e6a2f3232
parent64c466edde9c46c998c9771966345da1ea83e937 (diff)
downloadrequests-cache-86faa864900445e588b826004d594e8ab40a1c33.tar.gz
Bump dependencies
-rw-r--r--poetry.lock13
-rw-r--r--pyproject.toml6
2 files changed, 10 insertions, 9 deletions
diff --git a/poetry.lock b/poetry.lock
index aa78aed..87c7cd9 100644
--- a/poetry.lock
+++ b/poetry.lock
@@ -774,18 +774,19 @@ test = ["fixtures", "mock", "purl", "pytest", "sphinx", "testrepository (>=0.0.1
[[package]]
name = "responses"
-version = "0.10.15"
+version = "0.14.0"
description = "A utility library for mocking out the `requests` Python library."
category = "dev"
optional = false
-python-versions = ">=2.7, !=3.0.*, !=3.1.*, !=3.2.*, !=3.3.*"
+python-versions = ">=2.7, !=3.0.*, !=3.1.*, !=3.2.*, !=3.3.*, !=3.4.*"
[package.dependencies]
requests = ">=2.0"
six = "*"
+urllib3 = ">=1.25.10"
[package.extras]
-tests = ["coverage (>=3.7.1,<5.0.0)", "pytest-cov", "pytest-localserver", "flake8", "pytest (>=4.6,<5.0)", "pytest"]
+tests = ["coverage (>=3.7.1,<6.0.0)", "pytest-cov", "pytest-localserver", "flake8", "types-mock", "types-requests", "types-six", "pytest (>=4.6,<5.0)", "pytest (>=4.6)", "mypy"]
[[package]]
name = "rich"
@@ -1186,7 +1187,7 @@ yaml = ["pyyaml"]
[metadata]
lock-version = "1.1"
python-versions = "^3.7"
-content-hash = "b52b14c89f2e356007f8bb10a48f7b3a1f069545188d5c6994f8809d33b11d3f"
+content-hash = "6ffb70cf976fb4572ebbc0f4361a7598e16c1a053bc222626636769b44537575"
[metadata.files]
alabaster = [
@@ -1694,8 +1695,8 @@ requests-mock = [
{file = "requests_mock-1.9.3-py2.py3-none-any.whl", hash = "sha256:0a2d38a117c08bb78939ec163522976ad59a6b7fdd82b709e23bb98004a44970"},
]
responses = [
- {file = "responses-0.10.15-py2.py3-none-any.whl", hash = "sha256:af94d28cdfb48ded0ad82a5216616631543650f440334a693479b8991a6594a2"},
- {file = "responses-0.10.15.tar.gz", hash = "sha256:7bb697a5fedeb41d81e8b87f152d453d5cab42dcd1691b6a7d6097e94d33f373"},
+ {file = "responses-0.14.0-py2.py3-none-any.whl", hash = "sha256:57bab4e9d4d65f31ea5caf9de62095032c4d81f591a8fac2f5858f7777b8567b"},
+ {file = "responses-0.14.0.tar.gz", hash = "sha256:93f774a762ee0e27c0d9d7e06227aeda9ff9f5f69392f72bb6c6b73f8763563e"},
]
rich = [
{file = "rich-10.10.0-py3-none-any.whl", hash = "sha256:0b8cbcb0b8d476a7f002feaed9f35e51615f673c6c291d76ddf0c555574fd3c7"},
diff --git a/pyproject.toml b/pyproject.toml
index 8831a33..b0ed0a7 100644
--- a/pyproject.toml
+++ b/pyproject.toml
@@ -50,14 +50,14 @@ ujson = {optional=true, version=">=4.0"}
# All the bells and whistles for building documentation;
# defined here because readthedocs doesn't (yet?) support poetry.dev-dependencies
-furo = {optional=true, version=">=2021.8.11-beta.42"}
+furo = {optional=true, version=">=2021.9.8"}
linkify-it-py = {optional=true, version="^1.0.1"}
myst-parser = {optional=true, version="^0.15.1"}
sphinx = {optional=true, version="4.2.0"}
sphinx-autodoc-typehints = {optional=true, version="^1.11"}
sphinx-automodapi = {optional=true, version="^0.13"}
sphinx-copybutton = {optional=true, version=">=0.3,<0.5"}
-sphinx-inline-tabs = {optional=true, version="^2021.4.11-beta.9", python=">=3.8"}
+sphinx-inline-tabs = {optional=true, version="^2021.8.17b10", python=">=3.8"}
sphinx-notfound-page = {optional=true, version="*"}
sphinx-panels = {optional=true, version="^0.6"}
sphinxcontrib-apidoc = {optional=true, version="^0.3"}
@@ -91,7 +91,7 @@ pytest-cov = ">=2.11"
pytest-rerunfailures = "^10.1"
pytest-xdist = ">=2.2"
requests-mock = "^1.8"
-responses = "0.10.15"
+responses = "0.14"
timeout-decorator = "^0.5"
# Tools for linting, type checking, etc. are managed with pre-commit