summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--CHANGES.txt3
-rw-r--r--setup.cfg2
-rw-r--r--setup.py7
3 files changed, 11 insertions, 1 deletions
diff --git a/CHANGES.txt b/CHANGES.txt
index 83175ca..97c4dff 100644
--- a/CHANGES.txt
+++ b/CHANGES.txt
@@ -4,6 +4,9 @@ Changelog
After 0.5
---------
+- Added ``setup.py dev`` alias (runs ``develop`` plus installs ``nose``
+ and ``coverage``).
+
- Added support for CI under supported Pythons using Tox.
- Bug: Remove potential race condition on lock in face of interrupts
diff --git a/setup.cfg b/setup.cfg
index 262a22f..58269c8 100644
--- a/setup.cfg
+++ b/setup.cfg
@@ -8,3 +8,5 @@ nocapture=1
cover-package=repoze.lru
cover-erase=1
+[aliases]
+dev = develop easy_install repoze.lru[testing]
diff --git a/setup.py b/setup.py
index 9017640..3557650 100644
--- a/setup.py
+++ b/setup.py
@@ -24,6 +24,8 @@ except:
README = ''
CHANGES = ''
+testing_extras = ['nose', 'coverage']
+
setup(name='repoze.lru',
version='0.5',
description='A tiny LRU cache implementation and decorator',
@@ -54,5 +56,8 @@ setup(name='repoze.lru',
test_suite="repoze.lru",
entry_points = """\
""",
- )
+ extras_require = {
+ 'testing': testing_extras,
+ }
+)