summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--CHANGES.txt4
-rw-r--r--tox.ini11
2 files changed, 13 insertions, 2 deletions
diff --git a/CHANGES.txt b/CHANGES.txt
index b3cea4c..2a49f0a 100644
--- a/CHANGES.txt
+++ b/CHANGES.txt
@@ -4,6 +4,8 @@ Changelog
After 0.5
---------
+- Automated building Sphinx docs and testing example snippets under ``tox``.
+
- Added Sphinx documentation.
- Dropped support for Python 2.5.
@@ -15,7 +17,7 @@ After 0.5
- Added ``setup.py dev`` alias (runs ``develop`` plus installs ``nose``
and ``coverage``).
-- Added support for CI under supported Pythons using Tox.
+- Added support for CI under supported Pythons using ``tox``.
- Bug: Remove potential race condition on lock in face of interrupts
(Issue #10).
diff --git a/tox.ini b/tox.ini
index 5e30a82..66fc643 100644
--- a/tox.ini
+++ b/tox.ini
@@ -1,6 +1,6 @@
[tox]
envlist =
- py26,py27,py32,pypy,cover
+ py26,py27,py32,pypy,cover,docs
[testenv]
commands =
@@ -24,3 +24,12 @@ deps =
# we separate coverage into its own testenv because a) "last run wins" wrt
# cobertura jenkins reporting and b) pypy and jython can't handle any
# combination of versions of coverage and nosexcover that i can find.
+
+[testenv:docs]
+basepython =
+ python2.6
+commands =
+ sphinx-build -b html -d docs/_build/doctrees docs docs/_build/html
+ sphinx-build -b doctest -d docs/_build/doctrees docs docs/_build/doctest
+deps =
+ Sphinx