summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorChris McDonough <chrism@plope.com>2011-02-25 00:10:41 -0500
committerChris McDonough <chrism@plope.com>2011-02-25 00:10:41 -0500
commitac1fd7f3ccd28cad3a9a4d9e45954583fc513bbf (patch)
treed68670cfc8221839e08c7b2a4aeb331ebb1996ed /setup.py
parent646b8d7900dda5ded23671326ddbcd057ad11231 (diff)
downloadrepoze-lru-ac1fd7f3ccd28cad3a9a4d9e45954583fc513bbf.tar.gz
moved from svn
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py11
1 files changed, 6 insertions, 5 deletions
diff --git a/setup.py b/setup.py
index 8c9c8a0..57d31a2 100644
--- a/setup.py
+++ b/setup.py
@@ -16,14 +16,15 @@ __version__ = '0.3'
import os
-from ez_setup import use_setuptools
-use_setuptools()
-
from setuptools import setup, find_packages
here = os.path.abspath(os.path.dirname(__file__))
-README = open(os.path.join(here, 'README.txt')).read()
-CHANGES = open(os.path.join(here, 'CHANGES.txt')).read()
+try:
+ README = open(os.path.join(here, 'README.txt')).read()
+ CHANGES = open(os.path.join(here, 'CHANGES.txt')).read()
+except:
+ README = ''
+ CHANGES = ''
setup(name='repoze.lru',
version=__version__,