summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTres Seaver <tseaver@palladion.com>2012-03-23 17:10:57 -0400
committerTres Seaver <tseaver@palladion.com>2012-03-23 17:10:57 -0400
commitdc5b7930c4b64921c506797e6d55c7c84d9ea1bf (patch)
treec02a7f6ad44354bae1c36bc2f37e1b6ad47cb34c
parente18c6479a9277c8f69f79701775d9e8f26f79abd (diff)
downloadrepoze-lru-dc5b7930c4b64921c506797e6d55c7c84d9ea1bf.tar.gz
Changelog, note post-0.4 stuff.
-rw-r--r--CHANGES.txt21
-rw-r--r--setup.py2
2 files changed, 22 insertions, 1 deletions
diff --git a/CHANGES.txt b/CHANGES.txt
index 79038d2..591078d 100644
--- a/CHANGES.txt
+++ b/CHANGES.txt
@@ -1,3 +1,24 @@
+Changelog
+=========
+
+After 0.4
+---------
+
+- Feature: added a new "invalidate()" method to allow removal of items from
+ the cache (issue #8).
+
+- Bug: LRUCache.put() could take multiple seconds on large caches (Issue #7).
+
+- Bug: LRUCache was not thread safe (Issue #6).
+
+- Bug: LRUCache.clock would waste RAM (Issue #4).
+
+- Bug: repeated pushing of an entry would remove other cache entries
+ (Issue #3).
+
+- Bug: LRUCache would evict entries even when not full (Issue #2).
+
+
0.4 (2011-09-04)
----------------
diff --git a/setup.py b/setup.py
index 68c4416..de09881 100644
--- a/setup.py
+++ b/setup.py
@@ -25,7 +25,7 @@ except:
CHANGES = ''
setup(name='repoze.lru',
- version='0.4',
+ version='0.4+',
description='A tiny LRU cache implementation and decorator',
long_description=README + '\n\n' + CHANGES,
classifiers=[