summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTres Seaver <tseaver@palladion.com>2012-03-24 15:07:34 -0400
committerTres Seaver <tseaver@palladion.com>2012-03-24 15:07:34 -0400
commit53931cb3a6db4e9269f8102acf696ac500d179de (patch)
tree08132cc2a3656df942093440fa9bcc937a227b9d
parentdc710fe86f61c06bcacd27acb4544d5c1662f04d (diff)
downloadrepoze-lru-53931cb3a6db4e9269f8102acf696ac500d179de.tar.gz
Add tox support.
-rw-r--r--CHANGES.txt2
-rw-r--r--tox.ini49
2 files changed, 15 insertions, 36 deletions
diff --git a/CHANGES.txt b/CHANGES.txt
index 5e61235..83175ca 100644
--- a/CHANGES.txt
+++ b/CHANGES.txt
@@ -4,6 +4,8 @@ Changelog
After 0.5
---------
+- Added support for CI under supported Pythons using Tox.
+
- Bug: Remove potential race condition on lock in face of interrupts
(Issue #10).
diff --git a/tox.ini b/tox.ini
index 8c5d74e..c0a3fc5 100644
--- a/tox.ini
+++ b/tox.ini
@@ -1,47 +1,24 @@
[tox]
envlist =
- py25,py26,py27,py32,pypy
+ py26,py27,py32,pypy,cover
[testenv]
commands =
python setup.py test -q
+deps =
+ virtualenv
-# timing race conditions in tests cause a test under Jython 2.5 to fail:
-
-#.F.......................
-#======================================================================
-#FAIL: When timeout is given, decorator must eventually forget entries
-#----------------------------------------------------------------------
-#Traceback (most recent call last):
-# File "/home/chrism/projects/repoze.lru/.tox/jython/Lib/site-packages/repoze/l#ru/tests.py", line 512, in test_expiry
-# self.assertTrue(stop - start > 0.1)
-#AssertionError
-
-#[testenv:jython]
-#commands =
-# jython setup.py test -q
-
-# coverage reporting broken with namespace packages and pip/nose apparently.
-# It's not a tox thing or is it related to setuptools vs. distribute; once
-# tox creates the virtualenv with either setuptools or distribute, this
-# command finds no tests to run
-#
-# .tox/cover/bin/python setup.py nosetests
-#
-# which means it's something to do with nose probably
-
-# [testenv:cover]
-# basepython =
-# python2.7
-# commands =
-# python setup.py nosetests --with-xunit --with-xcoverage
-# deps =
-# nose
-# coverage==3.4
-# nosexcover
-# distribute = False
+[testenv:cover]
+basepython =
+ python2.6
+commands =
+ python setup.py nosetests --with-xunit --with-xcoverage
+deps =
+ virtualenv
+ nose
+ coverage
+ nosexcover
# we separate coverage into its own testenv because a) "last run wins" wrt
# cobertura jenkins reporting and b) pypy and jython can't handle any
# combination of versions of coverage and nosexcover that i can find.
-